加载中…
个人资料
李云龙
李云龙
  • 博客等级:
  • 博客积分:0
  • 博客访问:2,506,556
  • 关注人气:3,081
  • 获赠金笔:0支
  • 赠出金笔:0支
  • 荣誉徽章:
正文 字体大小:

通达信交易软件最好用股票买卖指标

(2014-05-08 16:55:24)
标签:

股票公式

股票指标源码

指标代码公式

股票

分类: 公式指标

 通达信交易软件最好用股票买卖指标 

 

买进指标
X0:=IF(C>=REF(C,1),AMOUNT/10000,0);
A1:=DATE <= 13181231;
十天线:MA(C,10),COLORGRAY;
工作线:(EMA(C,20)) * A1,POINTDOT,LINETHICK4,COLORYELLOW;
生命线:(MA(C,34)) * A1,LINETHICK2,COLORMAGENTA;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
STICKLINE(((C >= 工作线) AND (C >= O)),H,L,0,1),COLORRED;
STICKLINE(((C >= 工作线) AND (C >= O)),O,C,2,1),COLORRED;
STICKLINE(((C >= 工作线) AND (C <= O)),H,L,0,0),COLORRED;
STICKLINE(((C >= 工作线) AND (C <= O)),O,C,2,0),COLORRED;
STICKLINE(((C < 工作线) AND (C >= O)),H,L,0,1),COLORGREEN;
STICKLINE(((C < 工作线) AND (C >= O)),O,C,2,1),COLORGREEN;
STICKLINE(((C < 工作线) AND (C <= O)),H,L,0,0),COLORGREEN;
STICKLINE(((C < 工作线) AND (C <= O)),O,C,2,0),COLORGREEN;
工作线买卖的时机
工作线是股市上班休息“分水岭”。我们要学习做个智者,智者在下跌中买进好股票,在大家都买进时卖出股票。当你看中一只股票时是不是要立刻买进呢?如果你买进后就被套住,这说明你买贵了,你需要看工作线理论,你要在好股票下跌到工作线上面时买进,这时买错也要买。什么时候卖出呢?就是线下阳线卖。当然如果你一旦买错也要在股价反抽工作线时卖出,这时你的损失就是手续费,不要觉得麻烦,手续费是你钓鱼的鱼饵,如果你连鱼饵都舍不得出,那么我劝你立刻回家休息,远离毒品,远离股市。
记住下面的口诀:
线上阴线买,买错也要买;
线下阳线卖,卖错也要卖。

应用工作线理论必须注意,严格遵守纪律:股价必须要站在工作线和生命线上方。股价在工作线上方才能工作,股价在工作线下方不做交易。当股价高于生命线并在工作线上方时,才是最安全的买卖期。但也不是任何价格、任何股票都可买,首先要观查该股的基本面良好、行业不错、价位适中没有基金重仓、没有放过大量、没有大除权过的股票(首先是经济分析,了解市场热点,关注管理层的意图)。

在记住线上阴线买的同时也不要忘记工作线的卖出点:“线下大阳卖错了也要卖”这句话记在心里,时刻防范风险。这是精髓之处,把资金风险降到最低处。
或许,有人会问,这么频繁操作会不会损失太多手续费?
第一,前面讲过了手续费是你钓鱼的鱼饵,鱼饵是你必须要支付的。
第二,好股票买进的机会是不多的,回调工作线,就是你买进的机会,它一年之中可能仅仅有几次回踩工作线,回踩之后庄家就立刻拉起,机会只有很短的一天,而一旦跌破工作线则说明它已经由牛转熊,也不值得长期持有了。
如何应用工作线做短线
以工作线为中心,线上阴线买,买错也要买,线下阳线卖,卖错也要卖,工作线上持股,跌破工作线休息。
如何应用工作线做中长线
这个最简单,只要看看周工作线上面买进股票后,只要牛市不结束,就一路持股待涨,直到有明确的跌破周工作线卖出,股价很容易翻番哦,关键靠耐心!
从凯思斯博客中就可看出,我不是多头,也不是空头,我只做适合自己的行情,在牛市中也许做死多头坚决唱多不会大错,但是我还是坚持自己的操作理念,因为一旦熊市来了,你在牛市几年中赚到的利润很可能在几个月的持续调整中赔光,而套牢的时间也很可能长达几年!所以我坚持工作线上持股,工作线下抛出股票的纪律。工作线理论最适合牛市中做中线,如果你要想充分享受利润,不论是大盘还是个股,只要站在“工作线”上你就大胆在线上阴线买入持股,工作线理论是轻松赚钱的保证之一。
 

参考指标:控仓macd
{《控仓MACD》坐标参数:1.50;1.00;0.50;0.00;-0.50;-1.00;-1.50 这排数字贴在公式编辑器的坐标线长条窗内}
DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED,LINETHICK2;
DEA:EMA(DIF,9),COLORWHITE,LINETHICK2;
持仓段:0,COLOR00CFFF;
空仓段:0,COLORFFCCFF;
STICKLINE(DIF>DEA,-0.5,-0.6,10,1),COLOR00CFFF;
STICKLINE(DIF
DRAWTEXT(CROSS(DIF,DEA),DIF-0,'建仓'),COLORRED;
DRAWTEXT(CROSS(DEA,DIF),DIF+0,'空仓'),COLORGREEN;
MACD彩柱:(DIF-DEA)*2,COLORSTICK;
STICKLINE(((MACD彩柱0)),0,MACD彩柱,1,0),COLORLIBLUE,LINETHICK2;
STICKLINE(((MACD彩柱>REF(MACD彩柱,1)) AND (MACD彩柱<0)),0,MACD彩柱,1,0),COLORFF00FF,LINETHICK2;
建仓:IF(DIF<0,DIF,0),COLORYELLOW,LINETHICK2;
加仓:IF(DIF<0,0,DIF),COLORRED,LINETHICK2;
白线破仓:IF(DIF
趋势强弱:IF(DIF>DEA,DEA,DEA),COLORFF937F,LINETHICK2;
 
 
 
指数附图(通达信版本)
STICKLINE(INDEXC>INDEXO,INDEXC,INDEXO,1.5,1),COLORRED;
STICKLINE(INDEXC>INDEXO,INDEXC,INDEXH,0.01,1),COLORRED;
STICKLINE(INDEXC>INDEXO,INDEXO,INDEXL,0.01,1),COLORRED;
STICKLINE(INDEXC< INDEXO,INDEXC,INDEXO,1.5,0),COLORFFFF56;
STICKLINE(INDEXC< INDEXO,INDEXC,INDEXH,0.01,0),COLORFFFF56;
STICKLINE(INDEXC< INDEXO,INDEXO,INDEXL,0.01,0),COLORFFFF56;
MA1:MA(INDEXC,5),COLORWHITE;
MA2:MA(INDEXC,10),COLORYELLOW;
MA3:MA(INDEXC,20),COLORMAGENTA;
MA4:MA(INDEXC,30),COLORCC5555;
MA60:MA(INDEXC,60),COLORFFFF56;
MA120:MA(INDEXC,120),COLORGREEN;
 
 
指数副图源码
  
  STICKLINE(INDEXC>INDEXO,INDEXC,INDEXO,4,1),COLORRED;
  STICKLINE(INDEXC>INDEXO,INDEXC,INDEXH,0.5,1),COLORRED;
  STICKLINE(INDEXC>INDEXO,INDEXO,INDEXL,0.5,1),COLORRED;
  STICKLINE(INDEXC< INDEXO,INDEXC,INDEXO,4,0),COLORFFFF56;
  STICKLINE(INDEXC< INDEXO,INDEXC,INDEXH,0.5,0),COLORFFFF56;
  STICKLINE(INDEXC< INDEXO,INDEXO,INDEXL,0.5,0),COLORFFFF56;
  MA1:MA(INDEXC,5),COLORWHITE;
  MA2:MA(INDEXC,10),COLORYELLOW;
  MA3:MA(INDEXC,20),COLORMAGENTA;
  MA4:MA(INDEXC,30),COLORCC5555;
  MA60:MA(INDEXC,60),COLORFFFF56;
  MA120:MA(INDEXC,120),COLORGREEN
 
 
MA13:=MA(CLOSE,13);
EMA30:EMA(CLOSE,30),colorFFCCCC;
EMA60:EMA(CLOSE,60),colorFF00FF;
EMA90:EMA(CLOSE,90),COLORFFFF00;
EMA120:EMA(CLOSE,120),colorFFCC66;
EMA250:EMA(CLOSE,250),colorFF0000;
AA:=((((EMA30 + EMA60) + EMA90) + EMA120) / 4);
SX:=((AA * (1 / 100)) + AA);
XX:=(AA - (AA * (1 / 100)));
中粘A:=COUNT(((BETWEEN(EMA60,EMA90,XX) AND BETWEEN(EMA90,AA,EMA60)) AND BETWEEN(EMA120,EMA30,AA)),5);
UA:=((中粘A AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA30));
中粘B:=COUNT((((BETWEEN(EMA30,EMA60,XX) AND BETWEEN(EMA60,AA,EMA30)) AND BETWEEN(EMA90,EMA120,AA)) AND BETWEEN(EMA120,SX,EMA90)),5);
UB:=((中粘B AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,SX));
中粘C:=COUNT((((BETWEEN(EMA120,AA,XX) AND BETWEEN(EMA90,EMA60,AA)) AND BETWEEN(EMA30,EMA60,AA)) AND BETWEEN(EMA60,SX,EMA30)),5);
UC:=((((中粘C AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA30)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA60));
中粘D:=COUNT((((BETWEEN(EMA90,EMA120,XX) AND BETWEEN(EMA60,AA,EMA90)) AND BETWEEN(EMA120,AA,EMA90)) AND BETWEEN(SX,EMA30,AA)),5);
UD:=(((中粘D AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,AA));
中粘E:=COUNT((((BETWEEN(EMA30,EMA120,XX) AND BETWEEN(EMA120,EMA30,AA)) AND BETWEEN(EMA90,EMA60,AA)) AND BETWEEN(EMA60,SX,EMA90)),5);
UE:=(((中粘E AND CROSS(CLOSE,EMA30)) AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA90));
中粘F:=COUNT((((BETWEEN(EMA90,EMA60,XX) AND BETWEEN(EMA60,AA,EMA90)) AND BETWEEN(EMA120,AA,EMA90)) AND BETWEEN(EMA30,SX,AA)),5);
UF:=(((中粘F AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA30));
中粘G:=COUNT(((((BETWEEN(XX,AA,EMA30) AND BETWEEN(AA,EMA120,XX)) AND BETWEEN(EMA120,EMA60,AA)) AND BETWEEN(EMA60,EMA90,EMA120)) AND BETWEEN(EMA90,SX,EMA60)),5);
UG:=((中粘G AND CROSS(CLOSE,EMA30)) AND CROSS(CLOSE,EMA120));
中粘H:=COUNT((((BETWEEN(EMA120,EMA30,XX) AND BETWEEN(EMA30,AA,EMA120)) AND BETWEEN(EMA90,EMA60,AA)) AND BETWEEN(EMA60,SX,EMA90)),5);
UH:=(((中粘H AND CROSS(CLOSE,EMA30)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA60));
中粘Y:=COUNT(((((BETWEEN(EMA60,XX,EMA30) AND BETWEEN(XX,AA,EMA60)) AND BETWEEN(AA,SX,XX)) AND BETWEEN(SX,EMA90,AA)) AND BETWEEN(EMA90,EMA120,SX)),5);
UY:=((中粘Y AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA90));
中粘T:=COUNT((((BETWEEN(XX,EMA90,EMA120) AND BETWEEN(EMA90,EMA30,XX)) AND BETWEEN(EMA30,EMA60,EMA90)) AND BETWEEN(EMA60,SX,EMA30)),5);
UT:=(中粘T AND CROSS(CLOSE,XX));
中粘R:=COUNT(((BETWEEN(EMA60,SX,AA) AND BETWEEN(EMA90,SX,EMA60)) AND BETWEEN(EMA120,SX,EMA60)),5);
UR:=(((中粘R AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA120));
中粘W:=COUNT((((BETWEEN(EMA30,AA,XX) AND BETWEEN(EMA120,EMA60,EMA30)) AND BETWEEN(EMA60,EMA90,EMA120)) AND BETWEEN(EMA90,SX,EMA60)),5);
UW:=(中粘W AND CROSS(CLOSE,EMA120));
中粘J:=COUNT(((BETWEEN(EMA90,SX,EMA120) AND BETWEEN(EMA60,SX,EMA120)) AND BETWEEN(SX,EMA30,EMA60)),5);
UJ:=((中粘J AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,SX));
中线粘:=((((((((((((UA OR UB) OR UC) OR UD) OR UE) OR UF) OR UG) OR UH) OR UY) OR UT) OR UR) OR UW) OR UJ);
STICKLINE(中线粘,LOW,(LOW - 0.09),4,0),COLORFFFF00;
DRAWTEXT(中线粘,(LOW - 0.11),'中线粘'),COLORFFFF00;
AAL:=((((EMA60 + EMA90) + EMA120) + EMA250) / 4);
SXL:=((AAL * (1 / 100)) + AAL);
XXL:=(AAL - (AAL * (1 / 100)));
长粘A:=COUNT((((BETWEEN(EMA60,XXL,EMA90) AND BETWEEN(EMA90,EMA60,AAL)) AND BETWEEN(EMA120,AAL,EMA250)) AND BETWEEN(EMA250,SXL,EMA120)),5);
WA:=((长粘A AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA250));
长粘B:=COUNT((((BETWEEN(EMA90,AAL,XXL) AND BETWEEN(AAL,EMA90,EMA60)) AND BETWEEN(EMA60,AAL,EMA250)) AND BETWEEN(SXL,EMA60,EMA250)),5);
WB:=(((长粘B AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA250));
长粘C:=COUNT((((BETWEEN(EMA120,EMA90,XXL) AND BETWEEN(EMA90,AAL,EMA120)) AND BETWEEN(EMA60,EMA250,AAL)) AND BETWEEN(EMA250,SXL,EMA60)),5);
WC:=((长粘C AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA90));
长粘D:=COUNT((((BETWEEN(EMA120,AAL,XXL) AND BETWEEN(EMA90,AAL,XXL)) AND BETWEEN(EMA60,SXL,AAL)) AND BETWEEN(EMA250,SXL,AAL)),5);
WD:=((长粘D AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA250));
长粘E:=COUNT(((BETWEEN(EMA60,EMA90,XXL) AND BETWEEN(EMA90,EMA120,EMA60)) AND BETWEEN(SXL,EMA250,AAL)),5);
WE:=((长粘E AND CROSS(CLOSE,EMA120)) AND CROSS(CLOSE,EMA250));
长粘F:=COUNT((((BETWEEN(XXL,EMA60,AAL) AND BETWEEN(EMA90,EMA250,AAL)) AND BETWEEN(EMA250,EMA120,EMA90)) AND BETWEEN(EMA120,SXL,EMA250)),5);
WF:=((长粘F AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA250));
长粘G:=COUNT((((BETWEEN(EMA250,EMA60,XXL) AND BETWEEN(EMA60,EMA250,AAL)) AND BETWEEN(EMA90,EMA250,SXL)) AND BETWEEN(EMA120,SXL,EMA250)),5);
WG:=(((长粘G AND CROSS(CLOSE,EMA250)) AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA120));
长粘H:=COUNT(((BETWEEN(EMA60,EMA90,EMA30) AND BETWEEN(EMA90,EMA120,EMA60)) AND BETWEEN(EMA120,AAL,EMA90)),5);
WH:=(((长粘H AND CROSS(CLOSE,EMA60)) AND CROSS(CLOSE,EMA90)) AND CROSS(CLOSE,EMA120));
长粘:=(((((((WA OR WB) OR WC) OR WD) OR WE) OR WF) OR WG) OR WH);
STICKLINE(长粘,LOW,(LOW - 0.08),4,0),colorFFCC66;
DRAWTEXT(长粘,(LOW - 0.1),'长线粘'),colorFFCC66;

0

阅读 收藏 喜欢 打印举报/Report
  

新浪BLOG意见反馈留言板 欢迎批评指正

新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 产品答疑

新浪公司 版权所有