加载中…
正文 字体大小:

2014年CCNP路由备战笔记

(2014-08-12 14:22:03)
标签:

股票

分类: cisco

OSPF网络类型

 

#点到点

 

#广播型多路访问

  -通常出现在以太网

  -选举DR,BDR(即使是点到点的网络)

  -所有路由器与DR及BDR建立邻接关系

  -使用组播地址224.0.0.5及224.0.0.6

 

#NBMA网络选择ospf的模式

  -帧中继主接口,默认的OSPF模式为非广播

  -在点到点帧中继子接口上,默认的OSPF模式为点到点

  -在帧中继多点接口上,默认的ospf模式为非广播

 

底层 FR

 1.底层不支持广播(ospf不能建立邻接关系)

    解决方法:静态指邻居

 2.底层支持广播(配置broadcast)

    解决方法:更改端口的网络类型

                       静态指定邻居

 

#在子接口上运行帧中继

 2014年CCNP路由备战笔记

LSA类型

1类LSA:每台路由器都会产生的,关于自己直连链路的描述,并且只能在本区域泛洪

 

2类LSA:(在MA环境)每一个MA都有一个2类LSA,并且由DR产生,用来描述MA每一台路由器的信息,包括DR本身!只在本区域泛洪!

 

3类LSA:由(ABR)两个区域的边界路由器产生,就是把一个区域的1类LSA或2类LSA归纳之后,泛洪给另一个区域!

 

4类LSA:主机LSA,用来描述ASBR.

 

 

5类LSA:由ASBR(连接不同路由协议网络的路由器)向ospf注入,描述的是ospf域外的情况.只能在本区域泛洪!

2014年CCNP路由备战笔记

2014年CCNP路由备战笔记

ABR

   路由器有多个接口,至少有一个接口是连接主骨干区域的,其他接口属于非骨干区域。

 

LSA 类型5: 自治系统外LSA AS External LSA

   #OE1 ,OE2 的区别

   #OE1被重分布时分配的开销值,进入自治系统后需要相加!

   #OE2被重分布时分配的开销值,进入自治系统后无需相加,保持默认值!    

 

OSPF特殊区域

1.stub area (末梢区域)

   配置stub area 在该区域将不会出现 LSA类型4,5.(不理会外面的世界,但是还是知道去外面的路)不允许注入路由的(就是不能重分布)

  

自发添加默认路由*IA(LSA3)

 

优点:减少路由条目,又不影响网络的连接性

 

2. totally stub area(完全末梢区域)

配置后该区域不会出现LSA 3,4,5

自发添加默认路由IA

 

3.not-so-stubby area (非完全末梢区域 NSSA)

 

在stub基础修改,允许重分布,但是是特许的LSA7(存活在NSSA)

 

该被重分布的路由被标记 O N1或者O N2

 

LSA7只能存活在NSSA中,不能出去,如果需要被传递到其他的区域,需要被ABR转换为LSA5

 

不允许LSA 4或5 (就是说不允许其他的区域路由进入NSSA)

 

需要手动配置默认路由(IA)

 

4.totally NSSA (完全非完全末梢区域)

允许注入路由(重分布)

只存在1,2,7 LSA

会自动添加默认路由(IA)

 

...........................................................

特许区域的配置stub:(整个所在区域的路由器都需要配置)

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

area 1 stub

 

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

network 192.168.23.0 0.0.0.255 area 0

area 1 stub

 

特许区域的配置totally stub:(整个所在区域的路由器都需要配置)

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

network 192.168.23.0 0.0.0.255 area 0

area 1 stub no-summary

area 1 default-cost 10

特许区域的配置nssa:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

area 1 nssa (整个所在区域的路由器都需要配置)

 

ABR手工需要配置:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

network 192.168.23.0 0.0.0.255 area 0

area 1 nssa default-information-originate

 

 

特许区域的配置 完全nssa:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

area 1 nssa

area 1 nssa no-summary特许区域的配置nssa:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

area 1 nssa (整个所在区域的路由器都需要配置)

 

 2014年CCNP路由备战笔记

 

ABR手工需要配置:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

network 192.168.23.0 0.0.0.255 area 0

area 1 nssa default-information-originate

 

 

特许区域的配置 完全nssa:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

area 1 nssa

area 1 nssa no-summary

OSPF高级功能配置及认证

passive-interface :

router ospf 1

network 192.168.1.0 0.0.0.255 area 0

network 192.168.12.0 0.0.0.255 area 0

passive-interface fa0/0

 

ospf的被动接口:将不会收发路由更新,收发hello包,建立邻接关系。

rip的被动接口:不会主动发送路由更新,但是会收。

 

OSPF

1.passive-interface的实际应用:

@在大型网络中会有很多的端口需要被宣告

router ospf 1

network 1.1.1.0 0.0.0.0.255 area 0

network 2.2.2.0 0.0.0.0.255 area 0

network 3.3.3.0 0.0.0.0.255 area 0

network 4.4.4.0 0.0.0.0.255 area 0

passive-interface default (把所有的端口设为被动 ,快捷)

no passive-interface (排除无需被动的端口)

 

 2.注入默认路由,假若静态路由被取消了,那么注入默认路由也会随之被取消!

 

解决方法:default-information originate always

 

不管co路由器是否有静态路由,注入默认路由依然还在!

2014年CCNP路由备战笔记

3,路由汇总

在ospf当中有两种汇总的方式,分别应用于不同的场合

  a)外部路由的汇总:

配置在ASBR:

      router ospf 1

      summary-address 10.1.0.0 255.255.0.0

 

  b)区域间的汇总:(只能汇总本区域直连的路由)

配置在ABR:

    router ospf 1

    area 2 range 172.16.0.0 255.255.0.0

          ......

         区域号

 

4.Virtual-link

  背景:因为LSA的传输都要通过与骨干区域的直连传输

当标准区域不是跟骨干区域直连时,就会影响到路由的生成,所以Virtual-link是为标准区域与骨干区域直连架起直连的虚拟桥梁(传递LSA),但是这只是为解决问题暂用的方法,不是长远之计,长远之计是:所有的标准区域都要跟骨干区域直连!

 

配置:

R1:

 router ospf 1

 area 2 virtual-link  2.2.2.2

 

R2:

router ospf 1

area 2 virtual-link 3.3.3.3

附;2是指要承接的区域 ,后面的ip地址指向的是对方路由器的ID

 

特许区域的配置nssa:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

area 1 nssa (整个所在区域的路由器都需要配置)

 

ABR手工需要配置:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

network 192.168.23.0 0.0.0.255 area 0

area 1 nssa default-information-originate

 

 

特许区域的配置 完全nssa:

router ospf 1

network 192.168.12.0 0.0.0.255 area 1

area 1 nssa

area 1 nssa no-summary

ospf特殊区域:

 

OSPF的身份认证

1.Null

2.简单密码身份验证(明文)

3.MD5身份验证

4.接口认证

(明文):

router(config-if)#ip ospf authentication-key password

router(config-if)#ip ospf authentication

 

(密文)

router(config-if)#ip ospf message-digest-key key-id md5 key

router(config-if)#ip ospf authentication message-digest

 

5.区域认证

(明文)

router(config-if)#ip ospf authentication-key password

router(config-router)#area area-id authentication

 

(密文)

router(config-if)#ip ospf message-digest-key key-id md5 key

router(config-router)#area 0 authentication message-digest

 

6.Virtual-link 的认证:

(密文)(骨干区域的延伸)

router1(config-router)#area 1 virtual-link 3.3.3.3  message-digest-key 1 md5 key

 router1(config-router)#area 1  virtual-link authentication message-digest

 

 

router2(config-router)#area 1 virtual-link 2.2.2.2  message-digest-key 1 md5 key

 router2(config-router)#area 1  virtual-link authentication message-digest

 

ospf在工程中的运用

1.区域的划分:减少LSA的泛洪

2.路由的汇总:减少路由表的大小

3.主备线路(COST)

4.默认路由的传递

5.passive-interface

5.OSPF认证

 

路由重发布

1.度量值--默认种子度量值

(1)重发布的时候假若不设置metric值,使用默认会使重发布的路由无法传递

(2)重发布路由一定要在重分发路由器上有的路由!

2014年CCNP路由备战笔记

2有3种情况

 (1).动态路由协议之间

 (2).直连接口

 (3).静态路由

 

3.单点重分发

 (1)单向重分发

 (2)双向重分发

 

4.多点重发布(重要)

  (1)多点单向重分布

  (2)多点双向重分布

 

路由策略

(1)Passive-interface

 RIP/IGRP-----在指定接口不向外发送路由更新,但是接收路由更新

EIGRP----在指定接口不向外发送Hello消息,而且通过这个接口不与其他路由建立邻接关系,不发送其他EIGRP的数据流

OSPF---在指定接口不向外发送Hello消息,而且通过这个接口不与其他路由建立邻接关系,不发送和接收路由消息,(有些IOS版本中,OSPF在接口上发送Hello和DBD分组,但是不发送LSU)

 

 (2)passive-interface与单播更新

 步骤1:passive-interface

 步骤2:neighbor

 

注意:如何是EIGRP环境,需实现单播更新,那么路由更新接口不能被PASSIVE(这与RIP不一样),直接使用neighbor命令去指定邻居即可。如果接口一旦被PASSIVE,则即使手工指定了neighbor,也是无法正常建立EIGRP邻居关系

 

 

(记住) 最长匹配原则的使用

明细+汇总=实现数据的分流

 

 

管理距离控制路由

2014年CCNP路由备战笔记

 

实现需求(R2的路由表)

O 11.11.11.0

D 1.1.1.0

 

实现方式

access-list 1 permit 11.11.11.0

router eigrp

distance 130 10.1.1.12.1 0.0.0.0 1

解决双点双向重分发问题

(1)    常用distance

 

Router-map(与ACL类似)

1.关于route-map的case

    (1)是一个强大的路由策略工具

2.route-map的用途

  (1)重分布期间进行路由过滤或执行策略

 (2)PBR(策略路由)

 (3)NAT(网络地址转换)

  (4) BGP

a).用于重分发(匹配感兴趣路由数据)

 

b).执行路由策略

 

c).避免路由反馈(多点重分布时遇到的问题)

2014年CCNP路由备战笔记

 

Distribute-list (针对路由信息)

1.distribute-list 可根据下列因素过滤更新:

 a)入站接口

 b)出站接口

 c)从另一种路由协议重分发

 

2.对于距离矢量路由协议

  a)IN OUT 没有很大的问题

 

3.对于链路状态协议(传递的不是路由,而是LSA)

  a)本地始发的外部路由 实现才有效

in方向本地被过滤的路由,邻居还有

out方向,分发列表只能工作在执行路由重发布动作的那个ASBR上,且只能针对外部引入的路由起作用。因为OSPF执行重发布时,其实这些外部路由是以路由的形式引入进来的,因此分发列表在这个场合下能够正常工作,但是如果不是本地始发的外部路由,或者是内部的OSPF路由(就是通过network通告的网络),out方向的分发列表均束手无策。 

 

2014年CCNP路由备战笔记

2014年CCNP路由备战笔记

distribute-list

1. 在ospf中如果是用的network 的宣告的网络在out 方向是无法阻挡路由的分发的!

 

 Prefix-list (前缀列表)

作用:匹配路由,只能用于抓取路由的工具

 

而ACL可以做一些路由的放行,数据的过滤

 

分发列表是用于控制路由更新的一个工具,只能过滤路由信息,不能过滤LSA。因此:分发列表在距离矢量路由协议中使用,无论是in或者是out方向,都能正常的过滤路由。但是在链路状态路由协议中的工作就有点问题了。

 

路径控制

路径控制工具

.妥善的编址方案:VASM和CIDR

原则:可连续的,可汇总的,可扩展的

 

.重分布和路由协议的特征

.passive-interface

.distribute-list

.prefix-list

.AD的把控

.route-map

.路由标记

.offset-list

.cisco ios ip slas

.PBR

 

1.offset-list(偏移列表)

主要应用于RIP,.控制跳数

2014年CCNP路由备战笔记

2.PBR(策略路由Policy-Based routing )

(1).是router-map的一个应用

(2)主要对经过路由器的数据进行分流和过滤以及感兴趣数据流匹配

(3)基于策略的路由比传统路由能力更强,能够根据协议类型,报文大小,应用或ip源地址来选择转发路径

(4)PBR 的配置

应用PBR(对进入接口的数据流量生效,本地始发的流量无效)

router(config-if)#ip policy route-map map-tag

应用PBR(针对本地始发的流量生效)

router(config)#ip local policy route-map map-tag

(5)PBR 指定的路由优于本地的路由条目!

 

PBR的配置场景1.

2014年CCNP路由备战笔记

 

PBR的配置场景2(不安全,都需要cisco的设备)

当ISP1与GW之间有个运营商的透明设备,当ISP的端口down掉,PBR的配置场景1是无法知道,GW仍然会把数据发送到ISP 1,会造成一定的问题

 

当时配置场景2是可以知道ISP的路由故障,不会把数据发送给ISP

2014年CCNP路由备战笔记

PBR的配置场景3

2014年CCNP路由备战笔记

2014年CCNP路由备战笔记

配置场景4



2014年CCNP路由备战笔记

2014年CCNP路由备战笔记

 

1.EIGRP 协议特点

 

.cisco私有的增强型的距离矢量路由协议

.快速汇聚:采用DUAL来实现快速汇聚

.触发更新

.部分更新:EIGRP 发送部分更新,把更新的部分传递给需要的路由器

.支持多种网络协议:使用协议无关模块来支持

.使用多播和单播:多播地址224.0.0.10

.支持VLSM

.精密的度量值:能实现不等价的负载均衡

 

2.EIGRP 关键技术

.邻居发现协议

使用hello包

 

.可靠传输协议(RTP)

 

.DUAL有限状态机

选择最低的度量值和无环的路径到达目的的路径

.协议无关模块

 

3.EIGRP数据包

hello分组:以224.0.0.10发送,无需确认,高速链路时间间隔5s,低速链路时间间隔60s

更新

查询

应答

确认

 

 

metric的计算

带宽

延迟

 

k值与AS号相同就可以建立邻居关系--较ospf的简单

 

EIGRP默认路由

ip default-network network-number

1)必须主类路由指定

2)必须是eigrp获取到的!

 

.EIGRP负载均衡

.等价负载均衡

默认4条,最大16条

router(config-router)#Maximum-paths maximum-path

 

非等价均衡

router(config-router)#variance  multiplier

.multiplier默认值为1,范围1~128

.只有可行路径才会被负载均衡,可行条件为:

(1)路由必须是无环的。(即AD

(2)FD<=FD min x multiplier

.variance不指定最大路径,而指定了度量值得范围

 

优化EIGRP

1)陷入主动状态(SIA)

.路由器陷入主动状态并因此发起查询,仅当收到每个查询应答后,该路由器才会脱离主动状态进入被动状态

.如果路由器在3分钟内没有收到查询应答,路由将陷入主动状态(SIA),此时路由器将重置与未应答的邻居之间的邻接关系。

2)导致路由进入SIA的常见原因

.路由器太忙无法回答查询

.路由器之间的链路质量低劣

.单向链路

 

3)防范SIA

2014年CCNP路由备战笔记

4)限制查询范围

.在适当的路由器上使用路由汇总

.将远程路由器设置为stub eigrp

 

…………………………………………………………………………………………………………….

BGP基础

.主要应用于大规模的网络(金融..)

 

IGP主要是实现AS内的路由可达

BGP主要是实现AS之间的路由可达

 

 

关于BGP

.AS:指的是在同一个组织管理下使用相同策略的设备的集合

.不同AS通过AS号区分,AS号取值范围1-65535,其中64512-65535 是私有AS号,IANA负责AS号的分发。

.中国电信163 AS号:4134

.中国电信CN2 AS号:4809

.中国网通AS号:9929

 

目前有4个版本:主要用V4

 

使用BGP的三大理由

1)大量路由需要承载,IGP只能融纳千条,而BGP可以容纳上万

2)支撑MPLS/VPN的应用,传递客户VPN路由

3)策略能力强,可以很好的实现路由决策与数据控制

 

BGP特征

1)BGP使用TCP为传输层协议,TCP端口号179

2)BGP路由器之间建立TCP连接,这些路由器称为BGP对等体也叫BGP邻居:EBGP IBGP

3)对等体之间交换整个BGP路由表

4)BGP路由器只发送增量更新或触发更新(不会周期性更新)

5)具有丰富的路径属性

6)BGP通告成千上万的路哟u,可采用TCP滑动窗口的机制,停止并等待确认前,可以发送65576个字节

 

BGP不会自动发现邻居,需要手工指定

 

 

BGP Peer

1)EBGP:BGP位于不同自治系统的路由器之间,称为EBGP

.建立EBGP邻接关系,必须满足三个条件

-EBGP之间自治系统号不同

-定义邻居建立TCP会话

-neighbor中指定的ip地址要可达

 

2)IBGP邻接关系,满足的条件

-自治系统号相同

-定义邻居建立TCP会话

 

 

BGP同步

2014年CCNP路由备战笔记


2014年CCNP路由备战笔记


2014年CCNP路由备战笔记

BGP router-id

1)router(config-route)#bgp router-id x.x.x.x

     最好是手工配置,比较可靠

 

修改next-hop

》BGP是AS-by-AS的路由协议,而不是router-by-router的路由协议

》在BGP中,next-hop并不意味着是下一条路由器,而是到达下一个AS的ip地址

》EBGP中,默认next-hop为发送更新的邻居路由器的ip地址

》IBGP中,从EBGP传来的next-hop属性在IBGP中保持不变的被传递

2014年CCNP路由备战笔记

2014年CCNP路由备战笔记

BGP的认证

BGP的维护

软重置

.出站软重置

2014年CCNP路由备战笔记

 

.入站软重置

2014年CCNP路由备战笔记

BGP属性分为4类

 

1.公认必遵(well-known mandatory):BGP报文更新中必须包含的,且必须被所有的BGP厂商实现所能识别,包括ORIGIN,AS_PATH,

Next_Hop三个属性

 1)ORIGIN(起源):这个属性说明了源路由是怎么放到BGP列表中的。有3个可能的起源:IGP,EGP ,INCOMPLETE.路由器在多个路由选择的处理中使用这个信息,路由选择具有最低ORIGIN类型的路径,ORIGIN类型从低到高的顺序为:IGP>EGP>INCOMPLETE

 

2)AS_PATH(AS路径):指出包含在UPDATE报文中的路由信息所经过的自治系统的序列

 

3)Next-Hop(下一跳):声明路由器所获的BGP路由的下一跳,对EBGP会话来说,下一跳就是通告该路由器的邻居路由器的源地址

对于IBGP会话,有两种情况,一是起源AS内部的路由的下一跳就是通告该路由的邻居路由器的源地址,二是由EBGP注入AS的路由,它的下一跳会不变的带入IBGP中

 

2.公认自决(well-known discretionary):指必须被所有的BGP实现所有识别,但是在BGP更新报文可以发送,也可以不发送的属性,包括

LOCAL_PREF和ATOMIC_AGGREGATE两个属性

 

1)LOCAL_PREF(本地优先级):本地优先级属性是用于告诉自治系统内的路由器在有多条路劲的时候,怎么离开自治系统。本地优先级越高,路由优先级越高。,这个属性仅仅在IGBP内传递

 

2)ATOMIC_AGGREGATE(原子聚合):原子聚合属性指出已被丢失了的信息,当路由聚合时将会导致信息的丢失,因为聚合来自具有不同属性的不同源,如果一个路由器发送了导致信息丢失的聚合,路由器被要求将原子聚合属性附加到该路由上。

 

3.可选过度(optional transitive):可选过度属性并不要求所有的BGP实现都支持,如果该属性不能被BGP进程识别,它就会看过渡标志,如果过度标志被设置了,BGP进程会接收这个属性并将它不加改变的传递,包括:AGGPREGATOR , 和 COMMUNITY

 

1)AGGPREGATOR(聚合者):此属性标明了实施路由聚合的BGP路由器ID和聚合路由的路由器AS

 

2)COMMUNITY (团体):此属性指共享一个公共属性的一组路由器

 

4.可选非过渡(optinal nontransitive):可选非过渡属性并不要求所有的BGP实施都支持。如果这些属性被发送到不能被其识别的路由器,这些属性将会被丢弃,不能传送给BGP邻居,包括MED,ORIGINATOR_ID和CLUSTER_LIST.

 

1)MED(多出口区分):该属性通知AS外的路由器采用哪一条路径到达AS。它被认为路由的外部度量,低的MED值表示高的优先级,MED属性在自治系统间交换,但MED不能传递给第三方AS

 

2)ORIGINATOR_ID(起源ID):路由反射器会附加到这个属性上,它携带本AS源路由器的路由器ID,用以防环路。

 

3)CLUSTER_LIST.(簇列表):此属性显示了采用的反射路径。

 

 

 

本人学习CCNP 的时候主要是看红茶三杯的视频讲解,书籍就是

CCNP TSHOOT 642-832 Official Certification Guide
CCNP SWITCH 642-813 Official Certification Guide
CCNP ROUTE 642-902 Official Certification Guide

笔记做的不是很好,但是个人觉得能够理解就好,嘻嘻!

0

阅读 评论 收藏 转载 喜欢 打印举报
已投稿到:
  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

      

    新浪BLOG意见反馈留言板 电话:4006900000 提示音后按1键(按当地市话标准计费) 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有