加载中…
正文 字体大小:

安装包安装apache,包含可能发生的错误解决方案    pcre

(2012-05-14 18:31:32)
标签:

it

分类: 转载
安装apache 提示APR not found 解决方法

 推荐方法,注意版本号。

1.下载apr安装包:

http://labs.mop.com/apache-mirror//apr/apr-1.4.6.tar.gz

tar zxvf  apr-1.4.6.tar.gz

cd apr-1.4.6

./configure --prefix=/usr/local/apr

make && make install

2.下载apr-util安装包:

http://labs.mop.com/apache-mirror//apr/apr-util-1.4.1.tar.gz

tar zxvf apr-util-1.4.1.tar.gz

cd apr-util-1.4.1

./configure --prefix=/usr/local/apr-util --with-apr=/usr/local/apr/bin/apr-1-config

3.下载pcre安装包:

http://cdnetworks-kr-2.dl.sourceforge.net/project/pcre/pcre/8.30/pcre-8.30.zip

unzip pcre-8.30.zip

cd pcre-8.30

./configure --prefix=/usr/local/pcre

 make && make install

安装pcre-8.30时,make后可能会出现

  libtool: unrecognized option `-DHAVE_CONFIG_H'
  try `libtool --help' for more information

这样的错误,只要安装g++,再重新configure就可以了

4.安装httpd包:

http://labs.mop.com/apache-mirror/httpd/httpd-2.4.2.tar.gz

tar zxvf httpd-2.4.2.tar.gz

cd httpd-2.4.2

 ./configure --prefix=/usr/local/apache2 --enable-so --enable-rewrite --with-apr=/usr/local/apr --with-apr-util=/usr/local/apr-util --with-pcre=/usr/local/pcre/bin/pcre-config

make && make install

安装完成。

注: 下载最新版httpd包:

http://httpd.apache.org/dev/dist/httpd-2.4.2-deps.tar.bz2

http://httpd.apache.org/dev/dist/httpd-2.4.2.tar.bz2

解压安装 已集成APR,需安装pcre支持。

安装pcre同上3,

tar jxvf httpd-2.4.2.tar.bz2
tar jxvf httpd-2.4.2-deps.tar.bz2

cd httpd-2.4.2

./configure --prefix=/usr/local/apache2 --enable-so --enable-rewrite  --with-pcre=/usr/local/pcre/bin/pcre-config

 make && make install

0

阅读 评论 收藏 转载 喜欢 打印举报
前一篇:IE斜体浮动bug
后一篇:http状态
  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

    < 前一篇IE斜体浮动bug
    后一篇 >http状态
      

    新浪BLOG意见反馈留言板 电话:4006900000 提示音后按1键(按当地市话标准计费) 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有