加载中…
个人资料
liujun_live
liujun_live
  • 博客等级:
  • 博客积分:0
  • 博客访问:312,649
  • 关注人气:10
  • 获赠金笔:0支
  • 赠出金笔:0支
  • 荣誉徽章:
相关博文
推荐博文
谁看过这篇博文
加载中…
正文 字体大小:

openstack Pike for Centos7

(2017-09-20 09:28:21)
标签:

pike

openstack

centos7

nova

qemu-2.10

分类: 虚拟化/云计算/大数据
openstack Pike for Centos7

环境:
CentOS7.4
openstack pike

安装略,请参看openstack Ocata for centos7


错误1:Nova节点无法启动
ERROR oslo_service.service InternalError: Nova requires QEMU version 2.1.0 or greater
解决:
错误报的很明显,qemu版本必须>=2.1.0,但centos7默认的qemu版本为1.5.3,所以必须升级qemu
1.安装
yum -y install gcc gcc-c++ automake libtool bzip2-devel libuuid-devel spice-protocol spice-server-devel usbredir-devel bison flex libaio-devel libcap-devel libiscsi-devel
可选yum -y install git glib2-devel libfdt-devel pixman-devel zlib-devel 
tar xvJf qemu-2.10.1.tar.xz
cd qemu-2.10.1
./configure --enable-usb-redir --enable-libusb --enable-spice --enable-kvm --enable-bzip2 --prefix=/opt/qemu --enable-linux-aio --enable-system --target-list=x86_64-softmmu,x86_64-linux-user
make -j4 && make install
2.备份原始qemu
mv -f /usr/libexec/qemu-kvm{,.bak}
mv -f /usr/bin/qemu-img{,.bak}
mv -f /usr/bin/qemu-io{,.bak}
mv -f /usr/bin/qemu-nbd{,.bak}
3.建软链
ln -s /opt/qemu/bin/qemu-system-x86_64 /usr/libexec/qemu-kvm
ln -s /opt/qemu/bin/qemu-img /usr/bin/
ln -s /opt/qemu/bin/qemu-io /usr/bin/
ln -s /opt/qemu/bin/qemu-nbd /usr/bin/
4.重启nova-compute
systemctl restart openstack-nova-compute

0

阅读 评论 收藏 禁止转载 喜欢 打印举报/Report
  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

      

    新浪BLOG意见反馈留言板 电话:4000520066 提示音后按1键(按当地市话标准计费) 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有