加载中…
正文 字体大小:

总提示"未安装"或"请升级"的可能原因

(2015-02-26 09:56:44)
标签:

it

lodop

打印控件

原因有如下几种:

1:使用的64位浏览器,但提供给客户安装的Lodop是32位的,反之也一样,Lodop位数要与浏览器位数一致,与操作系统位数无关,总之尽量按Lodopfuncs.js提示的去做,不要人为自行判断。
2:IE11以上浏览器,则要求用Lodop6.1.5.8以上版本附带的lodopfuncs.js文件。
3:IE浏览器,注意查看是否误选了“ActiveX筛选”,查看途径:IE菜单->工具->ActiveX筛选(默认情况下不选)。
4:所安装Lodop版本号小于判断语句中比较的版本号,这种情况提示的是“请升级”(不是“未安装”)。
5:判断控件已安装(一般由LodopFuncs.js中getlodop实现,也有自己编写)的js过程有错误,建议对比lodop在线例子:http://www.mtsoftware.cn/demo.html
6:安装的Lodop版本太低(小于6.0.5.8)老控件受浏览器安全设置影响较大,尽量用Lodop最新版。
7:控件主文件(CAOSOFT_WEB_PRINT_lodop.ocx)被安全软件等警示(老版本易发生)且被操作者误选禁用或隔离。
8:如果是谷歌和火狐出问题,检查object是否设置为style:display:none 此时改用getlodop无参数方式可解决。
9:如果是Opera浏览器,查看一下是否开启了Turbo模式(或越野模式)。

10:如果是谷歌浏览器自动升级到Chrome33后出现问题,请参考如下文章解决:
http://blog.sina.com.cn/s/blog_721e77e50101cnxb.html
11:谷歌浏览器,进入chrome://settings/content 看看是否阻止了lodop或所有插件(另外看看谷歌启动时是否带了--disable-plugins 参数)。
12:谷歌浏览器,看看是否安装了ActiveX for Chrome扩展件,参考这篇文章解决一下:http://blog.sina.com.cn/s/blog_721e77e5010175ge.html

13:如果是Chrome42之后版本,支持NP插件默认处于关闭状态,要手工打开,方法如下:

在谷歌浏览器地址栏输入:

chrome://flags/#enable-npapi

然后找到“启用NPAPI”地方看到处于启用状态。

14:如果以上都不行,强烈建议您的系统干脆升级到“云打印”方式,关于云打印的优势参考:

http://blog.sina.com.cn/s/blog_721e77e50102w7ds.html

0

阅读 评论 收藏 转载 喜欢 打印举报
已投稿到:
  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

      

    新浪BLOG意见反馈留言板 不良信息反馈 电话:4006900000 提示音后按1键(按当地市话标准计费) 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有