加载中…
个人资料
六道缠
六道缠
  • 博客等级:
  • 博客积分:0
  • 博客访问:142,768
  • 关注人气:116
  • 获赠金笔:0支
  • 赠出金笔:0支
  • 荣誉徽章:
相关博文
推荐博文
谁看过这篇博文
加载中…
正文 字体大小:

博易指标--实例(二)

(2014-09-07 11:25:43)
分类: 期货

博易大师指标——投机点

VAR6:=(2*CLOSE+HIGH+LOW)/4;
 VAR7:=LLV(LOW,13);
 VAR8:=HHV(HIGH,13);
 VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
 VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);

STICKLINE(VAR9>VARA,VAR9,VARA,6,0),COLORRED;
 STICKLINE(VAR9<=VARA,VAR9,VARA,6,0),COLORGREEN;

AA:30,COLORYELLOW;
 BB:70,COLORYELLOW;

RSV:= (CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
 FASTK:=SMA(RSV,5,1);
 K:=SMA(FASTK,5,1);
 D:=SMA(K,3,1);

AA1:=K-REF(K,1);
 STICKLINE(AA1>0,REF(K,1),K,4,0),COLOR8000FF;
 STICKLINE(AA1<=0,REF(K,1),K,4,0),COLORFFFF00;


博易大师指标——波段操盘

RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
 Y0:SMA(RSV,3,1),COLORRED,LINETHICK1;
 Y1:SMA(Y0,3,1),COLORYELLOW,LINETHICK1;
 RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
 Y2:SMA(RSV1,5,1),COLORMAGENTA,LINETHICK4;
 Y3:SMA(Y2,10,1),COLORGREEN,LINETHICK4;
超卖:18,COLORWHITE;
超买:85,COLORBLUE;
 (Y0>Y1),STICK;
 (Y0<=Y1),STICK,COLOR80FFFF;
 (Y2>Y3),COLOR8000FF;
 (Y2<=Y3),COLOR00FF00;
 STICKLINE(Y0>Y1,Y0,Y1,0,1),COLORRED;
 STICKLINE(Y0
 STICKLINE(Y2>Y3,Y2,Y3,0,1),COLORMAGENTA;

DRAWTEXT(CROSS(Y3,Y2),Y3*1.03,'空'),COLOR00FFFF;
 DRAWTEXT(CROSS(Y2,Y3),Y3*0.91,'多'),COLORFFFF00;


博易大师指标——顶底

博易源码:

VAR1:=(EMA(C,12)-EMA(C,26))*100+50;
 VAR2:=EMA(VAR1,9);
 VAR3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
 VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
 VAR5:=SMA(VAR4,13,8);
 VAR6:=SMA(VAR3,21,8);
安全线:80,COLOR808000;
趋势:CEILING(SMA(VAR5,13,8)),LINETHICK2,COLOR0000FF;
底:IF((趋势-VAR6<(-65)),1,6),COLOR4080FF;
顶:IF((趋势-VAR6>85),95,100),COLORF0F000;
操盘线:MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),LINETHICK2,COLORGREEN;


文华源码:

VAR1:=(EMA(C,12)-EMA(C,26))*100+50;
 VAR2:=EMA(VAR1,9);
 VAR3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
 VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
 VAR5:=SMA(VAR4,13,8);
 VAR6:=SMA(VAR3,21,8);
 AQX:80,COLORCYAN;
 QS:CEILING(SMA(VAR5,13,8)),COLORRED;
 DI:IF((QS-VAR6<(-65)),1,6),COLORYELLOW;
 DIN:IF((QS-VAR6>85),95,100),COLORGREEN;
 CPX:MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),COLORGREEN;


博易大师指标——快慢多空线


ZZ:=IF(DATE>90501.00,10000,1); 
 Q:=(3*CLOSE+HIGH+LOW+OPEN)/6;

AA10:=EMA(Q,13);
 BB10:=ATAN((AA10-REF(AA10,1)))*180/3.1416;
 STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),8,0),COLORRED;
 STICKLINE(BB10<1 AND AA10>REF(AA10,1),AA10,REF(AA10,1),8,1),COLORGREEN;

DRAWNUMBER(ISLASTBAR,AA10,AA10,2),COLOR0000FF,ALIGN0;

AA20:=EMA(Q,34);
 BB20:=ATAN((AA20-REF(AA20,1)))*180/3.1416;
 STICKLINE(BB20>1,AA20,REF(AA20,1),8,0),COLORYELLOW;
 STICKLINE(BB20<1,AA20,REF(AA20,1),8,1),COLORBBCCCC;

DRAWNUMBER(ISLASTBAR,AA20,AA20,2),COLOR00FFFF,ALIGN0;

DRAWTEXT(CROSS(AA10,AA20),AA20*0.99871,'多'),COLOR0000FF;
 DRAWTEXT(CROSS(AA20,AA10),AA20*1.00239,'空'),COLOR00FF00;


博易大师指标——期货趋势多空

{周期 1 100 15 过滤 1 100 8 选股 -30 -20 -26 抄底 -50 -25 -40 }

VAR1:=EMA(CLOSE,8);
 VAR2:=EMA(CLOSE,13);
 VAR3:=EMA(CLOSE,21);
 VAR4:=EMA(CLOSE,55);
 VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
 VAR6:=(VAR5-REF(VAR5,15))/REF(VAR5,15)*100;
 VAR7:=(VAR5-REF(VAR5,15))/REF(VAR5,15)*100;
 VAR8:=EMA(VAR6,8);

STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6
 STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,5,0), COLOR62B3FF;
 STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,10,0),  COLORRED;
 STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,5,0),COLORFF00FF ;
 STICKLINE(VAR6REF(VAR8,1) AND VAR6>0,VAR6,VAR8,10,0),COLOR00FFFF ;
 STICKLINE(VAR6
 VAR9:=(CLOSE-MA(CLOSE,58))/MA(CLOSE,58)*100;
 VARA:=VAR9>1*REF(VAR9,1) AND VAR9<-26 AND VAR9>-40*1.5;
 VARB:=VOL/C*100;
 VARC:=LLV(LOW,50);
 VARD:=SUM(VOL,VARC);
 VARE:=HHV(HIGH,50);
 VARF:=SUM(VOL,VARE);
 VAR10:=(CLOSE-REF(OPEN,VARE))/REF(OPEN,VARE)*100;
 VAR11:=VARF/C*100;
 VAR12:=(CLOSE-REF(OPEN,VARC))/REF(OPEN,VARC)*100;
 VAR13:=VARD/C*100;
 VAR14:=MA(CLOSE,3);
 VAR15:=REF(CLOSE,2)*0.865;
 VAR16:=REF(CLOSE,13)*0.772;
 VAR17:=MIN(VAR15,VAR16);
 VAR18:=MA(CLOSE,13);
超跌: IF((CLOSE-VAR17)/CLOSE<0.03 AND VAR10<-35 AND SUM(VARB,5)/5<1.8,1,0)*10,  COLORWHITE;
 DRAWTEXT(超跌,超跌,' 抄底 '), COLORFF0000 ;
 VAR19:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
 VAR1A:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
 VAR1B:=EMA(VAR1A,9);
 VAR1C:=2*(VAR1A-VAR1B);
 DRAWTEXT(VAR1A<-50 AND VAR19>7 AND VAR1A
 DRAWTEXT(VAR1A<-50 AND VAR19>7 AND VAR1A>=VAR1B,5,'追'),   COLORWHITE;
 STICKLINE(VAR1A<-50 AND VAR19>7,0,-10,5,0),COLORFFFF00 ;

DRAWICON(VAR6>0,0-0.07,4);
 DRAWICON(VAR6<0,0+0.07,5);


博易大师指标——操盘线


Q:=(3*CLOSE+LOW+OPEN+HIGH)/6;
操盘线:(26*Q+25*REF(Q,1)+24*REF(Q,2)+23*REF(Q,3)+22*REF(Q,4)+21*REF(Q,5)
    +20*REF(Q,6)+19*REF(Q,7)+18*REF(Q,8)+17*REF(Q,9)+16*REF(Q,10)+15*REF(Q,11)+14*REF(Q,12)+13*REF(Q,13)+12*REF(Q,14)+11*REF(Q,15)
    +10*REF(Q,16)+9*REF(Q,17)+8*REF(Q,18)+7*REF(Q,19)+6*REF(Q,20)+5*REF(Q,21)+4*REF(Q,22)+3*REF(Q,23)+2*REF(Q,24)+REF(Q,26))/351,LINETHICK0,COLORRED;

空头线:=EMA(操盘线,7);

STICKLINE(操盘线>空头线,操盘线,空头线,4,0),COLORRED;
 STICKLINE(操盘线<空头线,操盘线,空头线,4,0),COLOR00FF00;

压力:MA(REF(HHV(C,30),1),2),COLOR808040,LINETHICK2;
支撑:MA(REF(LLV(C,30),1),2),COLOR808040,LINETHICK2;

 

如果不想要压力支撑就把

压力:MA(REF(HHV(C,30),1),2),COLOR808040,LINETHICK2;
支撑:MA(REF(LLV(C,30),1),2),COLOR808040,LINETHICK2;这2个不要就可以。

 

博易大师指标——索罗斯期货

 

红多绿空:EMA(CLOSE,3)*0.9993,COLORRED,LINETHICK0;

支撑线:EMA(CLOSE,55),COLORYELLOW,LINETHICK2;
压力线:EMA(CLOSE,144),COLORMAGENTA,LINETHICK2;

DIFF:=EMA(CLOSE,60) - EMA(CLOSE,100);
DEA:=EMA(DIFF,10);
MACD:=2*(DIFF-DEA);
DEA1:=MA(MACD,5),LINETHICK2,COLORFF8080;

PARTLINE(DEA1>0,红多绿空),COLORRED,LINETHICK3;
PARTLINE(DEA1<0,红多绿空),COLOR00FF00,LINETHICK3;


博易大师指标——稳赢趋势


HH:=HHV(HIGH,21);
LL:=LLV(LOW,21);
HH1:=BARSLAST((HH>REF(HH,1)));
LL1:=BARSLAST((LL
A:=IF((HH1 < LL1),1,IFELSE((HH1 > LL1),-1,0));
AA:IF(A>=0,LL,HH),COLORYELLOW;
STICKLINE(HH1<=LL1,O,C,4,1),COLORRED;
STICKLINE(HH1<=LL1,C,H,0.1,0),COLORRED;
STICKLINE(HH1<=LL1,L,O,0.1,0),COLORRED;
STICKLINE(HH1>LL1,O,C,4,0),COLORCYAN;
STICKLINE(HH1>LL1,C,H,0.1,1),COLORCYAN;
STICKLINE(HH1>LL1,L,O,0.1,1),COLORCYAN;
DRAWTEXT(CROSS(HH1,LL1),HH,'开空');
DRAWTEXT(CROSS(LL1,HH1),LL,'开多');

文华源码:

HH:=HHV(HIGH,21);
LL:=LLV(LOW,21);
HH1:=BARSLAST((HH>REF(HH,1)));
LL1:=BARSLAST((LL
A:=IFELSE((HH1 < LL1),1,IFELSE((HH1 > LL1),-1,0));
AA:IFELSE(A>=0,LL,HH),COLORYELLOW;
DRAWTEXT(CROSS(HH1,LL1),HH,'开空');
DRAWTEXT(CROSS(LL1,HH1),LL,'开多');
DRAWLINE(HH1>LL1,HIGH,HH1>LL1,OPEN,COLORCYAN);
DRAWLINE(HH1>LL1,LOW,HH1>LL1,CLOSE,COLORCYAN);
DRAWLINE(HH1<=LL1,HIGH,HH1<=LL1,CLOSE,COLORRED);
DRAWLINE(HH1<=LL1,LOW,HH1<=LL1,OPEN,COLORRED);
STICKLINE(HH1>LL1,OPEN,CLOSE,COLORCYAN,0);
STICKLINE(HH1<=LL1,OPEN,CLOSE,COLORRED,1);


博易大师指标——添财柱


Q:=(3*CLOSE+HIGH+LOW+OPEN)/6;
 DIFF :=EMA(Q,36)-EMA(Q,81),COLORFF00FF,LINETHICK3;
 DEA  :=EMA(DIFF,17),COLORRED,LINETHICK3;
 MACD :=2*(DIFF-DEA), COLORSTICK,LINETHICK7;
资金流量:=DIFF;

STICKLINE(DIFF>=0,0,DIFF,5,0),COLOR0000B3;
 STICKLINE(DIFF>=0,0,DIFF,4,0),COLOR0000C8;
 STICKLINE(DIFF>=0,0,DIFF,3,0),COLOR0000D7;
 STICKLINE(DIFF>=0,0,DIFF,2,0),COLOR0000EA;
 STICKLINE(DIFF>=0,0,DIFF,1,0),COLOR0000FF;{红柱消失卖出}
STICKLINE(DIFF<0,0,DIFF,5,0),COLOR00A600;
 STICKLINE(DIFF<0,0,DIFF,4,0),COLOR00B500;
 STICKLINE(DIFF<0,0,DIFF,3,0),COLOR00C600;
 STICKLINE(DIFF<0,0,DIFF,2,0),COLOR00D500;
 STICKLINE(DIFF<0,0,DIFF,1,0),COLOR00E600;{绿柱消失买入}

STICKLINE(DEA>=0,0,DEA,5,0),COLORYELLOW;
 STICKLINE(DEA>=0,0,DEA,4,0),COLORYELLOW;
 STICKLINE(DEA>=0,0,DEA,3,0),COLORYELLOW;
 STICKLINE(DEA>=0,0,DEA,2,0),COLORYELLOW;
 STICKLINE(DEA>=0,0,DEA,1,0),COLORYELLOW;
 STICKLINE(DEA<0,0,DEA,5,0),COLOR2266FF;
 STICKLINE(DEA<0,0,DEA,4,0),COLOR2266FF;
 STICKLINE(DEA<0,0,DEA,3,0),COLOR2266FF;
 STICKLINE(DEA<0,0,DEA,2,0),COLOR2266FF;
 STICKLINE(DEA<0,0,DEA,1,0),COLOR3388FF;

DRAWNUMBER(ISLASTBAR,资金流量,资金流量,2),COLORRED,ALIGN0;


博易指标---添財趋势


ZZ:=IF(DATE>90501.00,10000,1); 
 Q:=(3*CLOSE+HIGH+LOW+OPEN)/6;

Y:=(21*Q+20*REF(Q,1)+19*REF(Q,2)+18*REF(Q,3)+17*REF(Q,4)+16*REF(Q,5)+15*REF(Q,6)+14*REF(Q,7)+13*REF(Q,8)+12*REF(Q,9)+11*REF(Q,10)
    +10*REF(Q,11)+9*REF(Q,12)+8*REF(Q,13)+7*REF(Q,14)+6*REF(Q,15)+5*REF(Q,16)+4*REF(Q,17)+3*REF(Q,18)+2*REF(Q,19)+REF(Q,21))/231,LINETHICK0,COLOR0000FF;

添財線:=EMA(Y,2),LINETHICK0,COLORRED;

添財線哆:=(LLV(添財線,2)+LLV(添財線,5)+LLV(添財線,10)+LLV(添財線,15)+LLV(添財線,20))/5,POINTDOT,LINETHICK3,COLORFFFFFF;
添財線涳:=(HHV(添財線,2)+HHV(添財線,5)+HHV(添財線,10)+HHV(添財線,15)+HHV(添財線,20))/5,POINTDOT,LINETHICK3,COLOR2267FF;

添:(EMA(添財線哆,7) * 0.999),LINETHICK3,COLOR00FF00;
財:6*HHV(添,7)-5*添,LINETHICK3,COLORRED;

DRAWNUMBER(ISLASTBAR,添,添,2),COLOR0000FF,ALIGN0;


博易大师指标——平衡线


VAR1:=(3*CLOSE+HIGH+LOW+OPEN)/6;

顶部:=120,COLORFF11FF,LINETHICK2;
底部:=-20,COLORFF11FF,LINETHICK2;

VAR2:=LLV(LOW,100);
 VAR3:=HHV(HIGH,100);
平衡线:EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13),LINETHICK0,COLORRED;

SD:=EMA((EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13)),10);

多:IF(CROSS((EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13)),SD),40,10),LINETHICK2,COLORYELLOW;
空:IF(CROSS(SD,(EMA((VAR1-VAR2)/(VAR3-VAR2)*100,10))),60,90),LINETHICK2,COLORFFFF00;

∠平衡线角度:ATAN((平衡线/REF(平衡线,1)-1)*100)*180/3.1416,LINETHICK0,COLOR00FF00;

PARTLINE(平衡线>=REF(平衡线,17),平衡线),LINETHICK4,COLORRED;
 PARTLINE(平衡线

DRAWNUMBER(ISLASTBAR,平衡线,平衡线,2),COLORRED,ALIGN0;

 


博易大师指标——抄底逃顶

VA3:=DATE>901224 AND DATE<1991130;

Q:=(3*CLOSE+HIGH+LOW+OPEN)/6;

顶部:100,COLORFF11FF,LINETHICK2;
底部:0,COLORFF11FF,LINETHICK2;

RSV:=VA3*(Q-LLV(Q,27))/(HHV(Q,27)-LLV(Q,27))*100;
K:=VA3*SMA(RSV,27,11),COLORFF00FF,LINETHICK2;
D:=VA3*SMA(K,17,5),COLORYELLOW,LINETHICK2;
J:=VA3*3*K-2*D,COLORRED,LINETHICK0;

BB1:=EMA(J,7.7);
BB2:=REF(BB1,3.7);
趋势线:BB1,COLORRED;

STICKLINE(BB1>BB2,BB1,BB2,7,0),COLOR000045;
STICKLINE(BB1>BB2,BB1,BB2,5,0),COLOR000085;
STICKLINE(BB1>BB2,BB1,BB2,3,0),COLORRED;
STICKLINE(BB1>BB2,BB1,BB2,1,0),COLORFF11FF;

STICKLINE(BB1<=BB2,BB1,BB2,7,0),COLOR11FF11;
STICKLINE(BB1<=BB2,BB1,BB2,5,0),COLORFF22FF;
STICKLINE(BB1<=BB2,BB1,BB2,3,0),COLORYELLOW;
STICKLINE(BB1<=BB2,BB1,BB2,1,0),COLORRED;

∠趋势线角度:ATAN((趋势线/REF(趋势线,1)-1)*100)*180/3.1416,LINETHICK0,COLORRED;
DRAWNUMBER(ISLASTBAR,趋势线,趋势线,2),COLORRED,ALIGN0;

KF:=(EMA(Q,72)-EMA(Q,27))/2*0.95;
DF:=(EMA(Q,27)-EMA(Q,72))/2*0.95;
DT:=DF,COLORYELLOW;
KT:=KF,COLORCYAN;
PARTLINE(DF>KF,46),LINETHICK2,COLOR3C3CFF;
PARTLINE(KF>DF,54),LINETHICK2,COLOR40FF00;
DRAWICON(KF>DF,50,5);
DRAWICON(DF>KF,50,4);

VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
BQ:=IF(CROSS(10,VAR4),1,1),COLORYELLOW;
VAR5:=CROSS(VAR4,10) AND VAR3<12;
抄底:IF(VAR5,97,50),LINETHICK4,COLORWHITE;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,26);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,9);
VAR10:=EMA((0.667*REF(VAR9,1)+0.337*VAR9),2);
逃顶:IF(CROSS(VAR10,VAR9) AND VAR10>85,07,50),LINETHICK4,COLORFF8C1A;


博易指标--趋势底顶


VAR1:=(EMA(C,12)-EMA(C,26))*100+50;
VAR2:=EMA(VAR1,9);
VAR3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5:=SMA(VAR4,13,8);
VAR6:=SMA(VAR3,21,8);
趋势:CEILING(SMA(VAR5,13,8)),LINETHICK3,COLOR0000FF;
底:IF((趋势-VAR6<(-65)),49,0),LINETHICK3,COLOR4080FF;
顶:IF((趋势-VAR6>85),60,100),LINETHICK3,COLORF0F000;
操盘线:MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),LINETHICK2,COLORFFFFFF;

 

博易指标--主力


VAR1:=LLV(LOW,34);
 VAR2:=HHV(HIGH,30);
 VAR3:=REF(CLOSE,1);
 VAR4:=EMA((CLOSE-VAR1)/(VAR2-VAR1),3)*100;
主力:=SMA(MAX(CLOSE-VAR3,0),7,1)/SMA(ABS(CLOSE-VAR3),7,1)*100,COLORRED;
 CC:主力,COLORWHITE;
 VY:=SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,5,1);
 L2:=SMA(0.618*REF(VY,1)+0.382*VY,3,1), COLORFF9900;
 L3:=MA(L2,5);
 STICKLINE(L2>L3,L3+2,L3-2,5,0),COLORFFFF00;
 STICKLINE(L2<=L3,L3+2,L3-2,5,0),COLOR0000FF;
 80;
 50;
 20;


博易指标--金盆聚宝指标

VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR8:=LLV(LOW,35);
VARB:=HHV(HIGH,35);
BB:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,9);
金盆聚宝指标:EMA(0.667*REF(BB,1)+0.333*BB,2);
GC1:BB,POINTDOT,COLOR0000A8;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,13,1);
D1:=SMA(K1,13,1);
GC2:EMA(D1,3),POINTDOT,COLORYELLOW;
STICKLINE((BB-金盆聚宝指标>0),BB,金盆聚宝指标,6,0),COLOR0000A8;
STICKLINE((BB-金盆聚宝指标>0),BB,金盆聚宝指标,5,0),COLOR0000C0;
STICKLINE((BB-金盆聚宝指标>0),BB,金盆聚宝指标,4,0),COLOR0000E0;
STICKLINE((BB-金盆聚宝指标>0),BB,金盆聚宝指标,3,0),COLOR0000F0;
STICKLINE((BB-金盆聚宝指标>0),BB,金盆聚宝指标,2,0),COLOR0000D0;
STICKLINE((BB-金盆聚宝指标>0),BB,金盆聚宝指标,1,0),COLOR8080FF;
STICKLINE((BB-金盆聚宝指标<0),BB,金盆聚宝指标,6,0),COLORFFFFFF;
STICKLINE((BB-金盆聚宝指标<0),BB,金盆聚宝指标,5,0),COLORFFFFFF;
STICKLINE((BB-金盆聚宝指标<0),BB,金盆聚宝指标,4,0),COLORFFFFFF;
STICKLINE((BB-金盆聚宝指标<0),BB,金盆聚宝指标,3,0),COLORFFFFFF;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),8,0),COLORRED;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),7,0),COLOR1029FF;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),6,0),COLOR1040FF;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),5,0),COLOR1083FF;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),4,0),COLOR10ABFF;
DRAWTEXT(FILTER(CROSS(BB,金盆聚宝指标)AND BB<30 AND 金盆聚宝指标>REF(金盆聚宝指标,1)AND BB>=金盆聚宝指标,5),35,'减空');
DRAWICON(FILTER(CROSS(BB,金盆聚宝指标)AND BB<30 AND 金盆聚宝指标>REF(金盆聚宝指标,1)AND BB>=金盆聚宝指标,5),31,4);

DRAWTEXT(FILTER(CROSS(BB,金盆聚宝指标)AND BB<30 AND 金盆聚宝指标>REF(金盆聚宝指标,1)AND BB<=金盆聚宝指标,5),35,'追多');
DRAWICON(FILTER(CROSS(BB,金盆聚宝指标)AND BB<30 AND 金盆聚宝指标>REF(金盆聚宝指标,1)AND BB<=金盆聚宝指标,5),31,4);

DRAWTEXT(FILTER(BB55 AND BB>REF(BB,4)AND C>MA(C,15),7)AND BB>金盆聚宝指标,55,'减多');
DRAWICON(FILTER(BB55 AND BB>REF(BB,4)AND C>MA(C,15),7)AND BB>金盆聚宝指标,59,5);

DRAWTEXT(FILTER(BB92.5 AND BB>REF(BB,4)AND C>MA(C,15),7)AND BB<金盆聚宝指标,55,'追空');
DRAWICON(FILTER(BB92.5 AND BB>REF(BB,4)AND C>MA(C,15),7)AND BB<金盆聚宝指标,59,5);

GC3:   LLV(BB,198),POINTDOT,COLORGREEN;
GC4:   HHV(BB,188),POINTDOT,COLORGREEN;

DRAWTEXT(FILTER(GC4>REF(GC4,1),7),GC4-7,'将见顶');
DRAWICON(FILTER(GC4>REF(GC4,1),7),GC4,13);

CC:=(BB-金盆聚宝指标<0.3)AND (BB<25)AND CREF(C,1);
DD:=FILTER(CC,10);
DRAWTEXT(DD,15,'还有一跌');
DRAWICON(DD,19,9);

GG:=(BB-金盆聚宝指标<0.6)AND (BB<40)AND CREF(C,1);
HH:=FILTER(GG,10);
DRAWTEXT(HH,25,'逃底点'),COLOR43D0FA;
DRAWICON(HH,20,10);

EE:=(BB-金盆聚宝指标>0.55)AND (BB>70)AND C>MA(C,13)*0.96 AND C
FF:=FILTER(EE,10);
DRAWTEXT(FF,70,'逃高点'),COLOR43D0FA;
DRAWICON(FF,75,8);

DRAWTEXT(FILTER(GC3>REF(GC3,1),5)AND BB<40 AND 金盆聚宝指标>REF(金盆聚宝指标,1),GC3+6,'将见底');
DRAWICON(FILTER(GC3>REF(GC3,1),5)AND BB<40 AND 金盆聚宝指标>REF(金盆聚宝指标,1),GC3,11);

 

以上内容均属摘录,笔者只是借鉴熟悉博易指标编程,均存诸多漏洞,查阅者需慎重。

 


 

0

阅读 评论 收藏 转载 喜欢 打印举报/Report
  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

      

    新浪BLOG意见反馈留言板 电话:4000520066 提示音后按1键(按当地市话标准计费) 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有