加载中…
正文 字体大小:

在xcode中使用cocoapods

(2014-09-10 22:45:54)
标签:

cocoapods

pods

xcode

ios

分类: Iphone专区
首先要在机器上安装pods。

首先要把ruby的源切换一下,万恶的Q

gem sources --remove https://rubygems.org/

gem sources -a http://ruby.taobao.org/

gem sources -l

sudo gem install cocoapods

验证一下:pod --version

然后开始创建项目。随便创建一个项目,进入到项目的根目录,创建一个Podfile文件。(vim Podfile)

输入:

platform :ios, "7.0"

 

pod "AFNetworking", "~> 2.3"


命令行到项目根目录。pod update

会多出Podfile.lock,PodsTest.xcworkspace,Pods这三个文件。以后打开项目的时候用PodsTest.xcworkspace就ok了。如果需要添加类库,直接修改Podfile文件,然后pod update就可以了。


http://cocoapods.org/

可以搜索pods资源

0

阅读 评论 收藏 转载 喜欢 打印举报
  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

      

    新浪BLOG意见反馈留言板 电话:4006900000 提示音后按1键(按当地市话标准计费) 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有