加载中…
个人资料
多情贱客
多情贱客
  • 博客等级:
  • 博客积分:0
  • 博客访问:19,086
  • 关注人气:6
  • 获赠金笔:0支
  • 赠出金笔:0支
  • 荣誉徽章:
相关博文
推荐博文
谁看过这篇博文
加载中…
正文 字体大小:

关于Cisco Packet Tracer DHCP中继配置实验的更新

(2012-03-15 10:57:16)
标签:

科技

d9

路由器

配置

dhcp服务器

it

分类: 交换路由网络

  早在2008年曾经介绍过Cisco Packet Tracer,这个思科的网络设备模拟软件,并用它根据CCNA教材内容做了一些模拟实验,近日有一网友说根据我的实验操作时DHCP中继实验没有成功。(DHCP中继试验:《Packet Tracer 5.0建构CCNA实验攻略(16)——DHCP 中继配置》)我下面使得Cisco Packet Tracer 5.3重新做DHCP中继的实验,尽量做得详细一些,供大家参考。
  一、搭建实验环境
  添两个路由器与四个交换机及服务器、计算机。为Router 1841添加所需要的模块,并为这个设备重新命名,然后连接这些设备。在连接的时候要注意的就是两个路由器的串口相连时要知道哪一端是DTE,哪一端是DCE,是要为DCE上的串口配置clock rate参数。

关于Cisco <wbr>Packet <wbr>Tracer <wbr>DHCP中继配置实验的更新
图一


  在上图中,各个网络设备与计算机设备刚刚连接好,没有做任何配置。在此时,计算机(服务器)交换机是互相连通的,但交换机与路由器,路由器之间的链路是不通的,所以路由器之间相连的端口,交换机与路由器之间相连的端口是红色的。
  二、对设备做基本的配置
  1、配置路由器
  对路由器A的配置:

Router>
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/1
Router(config-if)#no shut    \\激活FastEthernet0/1端口\\

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config)#int fa0/0       \\激活FastEthernet0/0端口\\
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#
Router#

Router(config)#int s0/1/0
Router(config-if)#clock rate 56000  \\配置DCE端口的时钟频率\\
Router(config-if)#no shut             \\激活serial0/1/0\\

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
Router(config-if)#
  对路由器B的配置:
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z. 
Router(config)#hostname RouterB    \\为路由器B配置主机名\\
RouterB(config)#int s0/1/0
RouterB(config-if)#no shut     \\激活serial0/1/0\\

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

RouterB(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

RouterB(config-if)#int fa0/0     
RouterB(config-if)#no shut       \\激活FastEthernet0/0端口\\

RouterB(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

RouterB(config-if)#int fa0/1
RouterB(config-if)#no shut       \\激活FastEthernet0/1端口\\

RouterB(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

RouterB(config-if)#

关于Cisco <wbr>Packet <wbr>Tracer <wbr>DHCP中继配置实验的更新

图二 通过以上的配置,模拟实验环境中的设备链路已经连通


  三、网络参数配置,实现网络设备互相连通可以访问
  1、配置三个服务器:DNS、DHCP和WWW。为每台服务器配置IP地址(不要忘记配置网关)、在DHCP服务器上配置DHCP地址池等。

关于Cisco <wbr>Packet <wbr>Tracer <wbr>DHCP中继配置实验的更新

图三 DHCP地址池


  在一个DHCP服务器上添加两个DHCP地址池,为两个网段的计算机动态配置IP地址。
  2、配置两个路由器
路由器B:
RouterB>
RouterB>en
RouterB#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RouterB(config)#int fa0/1
RouterB(config-if)#ip address 192.168.9.1 255.255.255.0
RouterB(config-if)#int fa0/0
RouterB(config-if)#ip address 192.168.8.1 255.255.255.0
RouterB(config-if)#int s0/1/0
RouterB(config-if)#ip address 10.11.12.1 255.255.255.0
RouterB(config-if)#exit
RouterB(config)#router eigrp 10
RouterB(config-router)#network 192.168.9.0
RouterB(config-router)#network 192.168.8.0
Router(config-router)#network 10.11.12.0
RouterB(config-router)#
路由器A的配置:
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int s0/1/0
Router(config-if)#ip address 10.11.12.2 255.255.255.0
Router(config-if)#int fa0/0
Router(config-if)#ip address 172.16.16.1 255.255.255.0
Router(config-if)#int fa0/1
Router(config-if)#ip address 172.16.18.1 255.255.255.0
Router(config-if)#exit
Router(config)#router eigrp 10
Router(config-router)#network 172.16.16.0
Router(config-router)#network 172.16.18.0
Router(config-router)#network 10.11.12.0
  通过以上的配置,在虚拟实验环境的中的网络已经完全畅通。

关于Cisco <wbr>Packet <wbr>Tracer <wbr>DHCP中继配置实验的更新

图四 用DHCP Server ping路由器A的两个Fast Ethernet端口


  三、在路由器A上配置DHCP中继
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip helper-address 192.168.8.3
Router(config-if)#int fa0/1
Router(config-if)#ip helper-address 192.168.8.3
Router(config-if)#
  四、配置客户端通过DHCP方式配置IP地址

关于Cisco <wbr>Packet <wbr>Tracer <wbr>DHCP中继配置实验的更新

图五 172.16.16.0网段的计算机通过DHCP配置IP地址

关于Cisco <wbr>Packet <wbr>Tracer <wbr>DHCP中继配置实验的更新

图六  172.16.18.0网段的计算机通过DHCP配置IP地址

关于Cisco <wbr>Packet <wbr>Tracer <wbr>DHCP中继配置实验的更新

图七 客户计算机访问虚拟网络环境中的WWW服务器

关于Cisco <wbr>Packet <wbr>Tracer <wbr>DHCP中继配置实验的更新

图八 通过ping命令测测网络


  通过上面的配置,已经完了DHCP中继的配置。在配置的过程中一定要细心,不要遗漏一些配置。


0

阅读 评论 收藏 禁止转载 喜欢 打印举报/Report
  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

      

    新浪BLOG意见反馈留言板 电话:4000520066 提示音后按1键(按当地市话标准计费) 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有