加载中…
个人资料
小宇
小宇
  • 博客等级:
  • 博客积分:0
  • 博客访问:101,823
  • 关注人气:20
  • 获赠金笔:0支
  • 赠出金笔:0支
  • 荣誉徽章:
相关博文
推荐博文
谁看过这篇博文
加载中…
正文 字体大小:

华为NAT配置(转)

(2014-03-27 17:09:20)
标签:

it

分类: 路由和交换技术

                             华为NAT配置(转)  

配置脚本

#

sysname RouterA

#

radius scheme system

#

domain system

#

acl number 2000                    /配置允许进行NAT转换的内网地址段/

rule 0 permit source 192.168.0.0 0.0.0.255

rule 1 deny

#

interface Ethernet0/0

ip address 202.1.1.2 255.255.255.248

nat outbound 2000

#

interface Ethernet0/1          

ip address 192.168.0.1 255.255.255.0         /内网网关/

#

interface NULL0

#

ip route-static 0.0.0.0 0.0.0.0 202.1.1.1 preference 60   /配置默认路由/

#

user-interface con 0

user-interface vty 0 4

#

return

配置脚本

#

sysname RouterA

#

nat address-group 0 202.1.1.3 202.1.1.6    /用户NAT的地址池/

#

radius scheme system

#

domain system

#

acl number 2000                    /配置允许进行NAT转换的内网地址段/

rule 0 permit source 192.168.0.0 0.0.0.255

rule 1 deny

#

interface Ethernet0/0

ip address 202.1.1.2 255.255.255.248

nat outbound 2000 address-group 0    /在出接口上进行NAT转换/

#

interface Ethernet0/1

ip address 192.168.0.1 255.255.255.0         /内网网关/

#

interface NULL0

#

ip route-static 0.0.0.0 0.0.0.0 202.1.1.1 preference 60   /配置默认路由/

#

user-interface con 0

user-interface vty 0 4

#

return

5.2.4 对外提供ftpwww等服务

www服务为例,除了5.2.15.2.2的配置,公网接口需要增加如下配置:

[Quidway-Ethernet0/0]nat server protocol tcp global 202.1.1.2 www inside 192.168.0.2 www

注意:如果需要其他用户可以ping通内部对外提供服务的服务器,必须增加如下配置:

[Router-Ethernet1]nat server protocol icmp global 202.1.1.2 inside 192.168.0.2

注意:内部用户不能使用公网地址来访问内部服务器,必须使用内网地址访问.

如上例子:192.168.0.0/24网段的用户,不能访问http://202.1.1.2,而只能访问http://192.168.0.2

配置脚本

#

sysname RouterA

#

radius scheme system

#

domain system

#

acl number 2000                    /配置允许进行NAT转换的内网地址段/

rule 0 permit source 192.168.0.0 0.0.0.255

rule 1 deny

#

interface Ethernet0/0

ip address 192.168.0.1 255.255.255.0              /内网网关/

nat outbound 2000

#

interface Serial0/0          

ip address 202.1.1.2 255.255.255.252              /公网出口/

nat outbound 2000                           /在出接口上进行NAT转换/

#

interface Serial0/1          

ip address 61.1.1.2 255.255.255.252              /公网出口/

nat outbound 2000

#

interface NULL0

#

ip route-static 0.0.0.0 0.0.0.0 202.1.1.1 preference 60   /配置默认路由/

ip route-static 0.0.0.0 0.0.0.0 61.1.1.1 preference 60    /配置默认路由/

#

user-interface con 0

user-interface vty 0 4

#

return

【验证】

disp ip rout

Routing Table: public net

Destination/Mask   Protocol Pre  Cost        Nexthop         Interface

0.0.0.0/0          STATIC   60            61.1.1.1        Serial0/1

                                             202.1.1.1       Serial0/0

61.1.1.0/30        DIRECT              61.1.1.6        Serial0/1

61.1.1.2/32        DIRECT              61.1.1.5        Serial0/1

61.1.1.1/32        DIRECT              127.0.0.1       InLoopBack0

127.0.0.0/8        DIRECT              127.0.0.1       InLoopBack0

127.0.0.1/32       DIRECT              127.0.0.1       InLoopBack0

192.168.0.0/24     DIRECT              192.168.0.1     Ethernet0/0

192.168.0.1/32     DIRECT              127.0.0.1       InLoopBack0

202.1.1.0/30       DIRECT              202.1.1.6       Serial2/0/0

202.1.1.2/32       DIRECT              202.1.1.5       Serial2/0/0

202.1.1.1/32       DIRECT              127.0.0.1       InLoopBack0

disp nat session

There are currently 2 NAT sessions:

Protocol      GlobalAddr  Port      InsideAddr  Port        DestAddr  Port

            202.1.1.2 12288     192.168.0.2  1036       200.1.1.1    23

VPN:  0,        status:    11,        TTL: 24:00:00,       Left: 23:59:55

             61.1.1.2 12289     192.168.0.3  1035       200.1.1.1    23

VPN:  0,        status:    11,        TTL: 00:01:00,       Left: 00:00:21

【提示】

1  通过在路由上配置两条等值路由来实现负载分担

2  如果只想实现NAT的主备用,只需要修改两条默认路由为不同的优先级即可

0

阅读 评论 收藏 转载 喜欢 打印举报/Report
  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

      

    新浪BLOG意见反馈留言板 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有