centos7安装mysql(glibc版)
首先去官网上(http://dev.mysql.com/downloads/mysql/)下载,注意选择Linux平台,http://s13/small/006vIKuogy72ExVzf8o9c&690
Centos7可通过uname -a 查看操作系统信息,
http://s14/bmiddle/006vIKuogy72EybD5gh3d&690
解释下 x86 表示32 bit,x86_64 表示64
bit,小编下载的是mysql-5.7.13-linux-glibc2.5-x86_64.tar版本,通过FileZilla拖到/usr/local下,.tar文件可以通过tar
xvf解压,解压后发现
http://s13/bmiddle/006vIKuogy72Eyoxdfu2c&690
出来了两个,不过无所谓啦,小编用的是没有test的那个,之前说过.tar.gz可以通过tar -zxvf解压,解压后再home文件夹下创建一个mysql文件夹,作为存放mysql文件的目录
http://s13/small/006vIKuogy72EyCsEDW8c&690
回到保存下载压缩文件的目录解压压缩文件
http://s6/bmiddle/006vIKuogy72EyMEYvP25&690
移动文件到指定目录
http://s9/mw690/006vIKuogy72EyODeJye8&690
安装运行mysql所需要的包
yum search libaio
yum install libaio
接下来,添加一个mysql用户组
groupadd mysql
设置 -s /bin/false 表示mysql不能作为登入用户
useradd -r -g mysql -s /bin/false mysql
在/usr/local/目录下创建一个mysql链接
ln -s /home/mysql/mysql-5.7.13 mysql
cd mysql
mkdir data
//作为存放数据的目录
chmod 770 data
chown -R mysql .
(注意后面的.)
chgrp -R mysql .
bin/mysqld --initialize --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data
执行该命令后,注意划红线的部分
http://s13/bmiddle/006vIKuogy72EAewCuw5c&690
这个是初始密码,首次登入的时候需要,建议先复制出来一份!!!
接着,
bin/mysql_ssl_rsa_setup --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data/
chown -R root .
chown -R mysql data
cd /var/log
mkdir mariadb
//作为存放数据库运行日志的文件夹
cd /usr/local/mysql
bin/mysqld_safe --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data &
将mysql加入到可控制启动服务的文件夹内,并命名为mysql,即service可控制的服务名,到时可用service mysql start|stop 控制启动及关闭mysql
cp support-files/mysql.server /etc/init.d/mysql
到/etc/目录下配置my.cnf
cd /etc/
vi my.cnf
//修改或添加以下内容
http://s5/bmiddle/006vIKuogy72EAzDl5O34&690
注意,basedir,datadir,socket文件内有的话就修改,没有的话就添加,不要重复添加,否则到后面会报错
配置环境变量,添加如下内容
vi /etc/profile
exportMYSQL_HOME="/usr/local/mysql"
exportPATH="$PATH:$MYSQL_HOME/bin"
使配置及时生效
source /etc/profile
至此可用service mysql start 来启动
配置开机启动mysql服务
chkconfig --add mysql
chkconfig --level 2345 mysql on
http://s16/bmiddle/006vIKuogy72EAPdAkLdf&690
首次登入mysql
http://s15/bmiddle/006vIKuogy72EARIUCWbe&690
输入之前生成的临时密码
登入后可修改密码
http://s7/bmiddle/006vIKuogy72EAWmiTc16&690
OK!
说明:有错误的地方,欢迎大家提意见,共同进步!!http://www/uc/myshow/blog/misc/gif/E___6715EN00SIGG.gif
Centos7可通过uname -a 查看操作系统信息,
http://s14/bmiddle/006vIKuogy72EybD5gh3d&690
解释下
http://s13/bmiddle/006vIKuogy72Eyoxdfu2c&690
出来了两个,不过无所谓啦,小编用的是没有test的那个,之前说过.tar.gz可以通过tar -zxvf解压,解压后再home文件夹下创建一个mysql文件夹,作为存放mysql文件的目录
http://s13/small/006vIKuogy72EyCsEDW8c&690
回到保存下载压缩文件的目录解压压缩文件
http://s6/bmiddle/006vIKuogy72EyMEYvP25&690
移动文件到指定目录
http://s9/mw690/006vIKuogy72EyODeJye8&690
安装运行mysql所需要的包
yum search libaio
yum install libaio
接下来,添加一个mysql用户组
groupadd mysql
设置 -s /bin/false 表示mysql不能作为登入用户
useradd -r -g mysql -s /bin/false mysql
在/usr/local/目录下创建一个mysql链接
ln -s /home/mysql/mysql-5.7.13 mysql
cd mysql
mkdir data
chmod 770 data
chown -R mysql .
chgrp -R mysql .
bin/mysqld --initialize --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data
执行该命令后,注意划红线的部分
http://s13/bmiddle/006vIKuogy72EAewCuw5c&690
这个是初始密码,首次登入的时候需要,建议先复制出来一份!!!
接着,
bin/mysql_ssl_rsa_setup --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data/
chown -R root .
chown -R mysql data
cd /var/log
mkdir mariadb
cd /usr/local/mysql
bin/mysqld_safe --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data &
将mysql加入到可控制启动服务的文件夹内,并命名为mysql,即service可控制的服务名,到时可用service mysql start|stop 控制启动及关闭mysql
cp support-files/mysql.server /etc/init.d/mysql
到/etc/目录下配置my.cnf
cd /etc/
vi my.cnf
http://s5/bmiddle/006vIKuogy72EAzDl5O34&690
注意,basedir,datadir,socket文件内有的话就修改,没有的话就添加,不要重复添加,否则到后面会报错
配置环境变量,添加如下内容
vi /etc/profile
export
export
使配置及时生效
source /etc/profile
至此可用service mysql start 来启动
配置开机启动mysql服务
chkconfig --add mysql
chkconfig --level 2345 mysql on
http://s16/bmiddle/006vIKuogy72EAPdAkLdf&690
首次登入mysql
http://s15/bmiddle/006vIKuogy72EARIUCWbe&690
输入之前生成的临时密码
登入后可修改密码
http://s7/bmiddle/006vIKuogy72EAWmiTc16&690
OK!
说明:有错误的地方,欢迎大家提意见,共同进步!!http://www/uc/myshow/blog/misc/gif/E___6715EN00SIGG.gif

加载中…