加载中…

加载中...

正文 字体大小:

[转载]主图青云直上及三副图、三个选股指标源码

(2019-02-10 11:03:42)
标签:

转载

指标缺失部分 以文档记录为准

交易之道 刚者易折 唯有至阴至柔 方可纵横天下。
心态第一理念第二技术第三,趋势第一风险第二时机第三。
纪律第一系统第二修炼第三,止损第一止盈第二时间第三。

主图青云直上

AA05:MA(C,5),LINETHICK3,COLOR00CCFF;
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND AA05>REF(AA05,1), AA05,DRAWNULL),LINETHICK3,COLORRED;
AA10:MA(C,10);AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND AA05
AA30:MA(C,30);
三拾日乖离率:(C-AA30)/AA30*100,NODRAW;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
IF(BB30>15 AND AA30>REF(AA30,1), AA30,DRAWNULL),LINETHICK3,COLORFF00FF;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05
DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
DRAWTEXT(MV>6 AND L<=LLV(L,10),L*0.95,'←异动'),COLORCYAN;

附图1-黄金倍量柱
 
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
AA:=VOL>=REF(V,1)*1.91 && C>REF(C,1);
AA1:=VOL
AA2:=VOL
AA3:=ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.05;
STICKLINE(AA,0,V,1,0),COLORYELLOW;
STICKLINE(AA1,0,V,1,0),COLORGREEN;
STICKLINE(AA2,0,V,1,0),COLORMAGENTA;
STICKLINE(AA3,0,V,1,0),COLORWHITE;
MV1:MA(VOL,5);
MV2:MA(VOL,10);
DRAWTEXT(CURRBARSCOUNT=40,HHV(V,80)*1.9,'黄柱倍量,洋红百日地量,绿柱缩量,白柱平量');
 
附图2
黑马雷达
A1:=1;
A2:=(5);
A3:=(((2 * CLOSE) + HIGH) + LOW) / 4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3 - A4) / (A5 - A4)) * 100),13);
A7:=(EMA(((0.667 * (REF(A6,1))) + (0.333 * A6)),2)) * A1;
决策线:(EMA(A7,A2)) * A1,COLORRED;
A8:=(HHV(HIGH,9)) - (LLV(LOW,9));
A9:=(HHV(HIGH,9)) - CLOSE;
A10:=CLOSE - (LLV(LOW,9));
A11:=((A9 / A8) * 100) - 70;
A12:=((CLOSE - (LLV(LOW,60))) / ((HHV(HIGH,60)) - (LLV(LOW,60)))) * 100;
A13:=SMA(((A10 / A8) * 100),3,1);
A14:=(SMA(A13,3,1)) - (SMA(A11,9,1));
A15:=IF((A14 > 100),(A14 - 100),0);
A16:=(EMA((((A3 - A4) / (A5 - A4)) * 100),8)) * A1;
A17:=(EMA(A16,5)) * A1;
STICKLINE(((A16 - A17) > 0),A16,A17,3,1),COLORFFAA18;
STICKLINE(((A16 - A17) < 0),A16,A17,3,0),COLORGREEN;
A18:=(EMA(CLOSE,2)) * A1;
A19:=(EMA((((SLOPE(CLOSE,21)) * 20) + CLOSE),42)) * A1;
A20:=(HHV((MA(HIGH,13)),13)) * A1;
A21:=(LLV((MA(HIGH,13)),1)) * A1;
A22:=(EMA(CLOSE,4)) * A1;
A23:=((((A18 >= A19) AND (A21 = A20)) AND (A18 > A22)) AND (CLOSE > A21)) AND ((REF(A21,1)) < (REF(A20,1)));
A24:=BARSLAST(A23) + 1;
A25:=(LLV(LOW,A24)) * 1.3;
A26:=(LLV(LOW,20)) * 1.418;
A27:=(((((A18 >= A19) AND (A21 = A20)) AND ((CLOSE / (REF(CLOSE,1))) >= 1.07)) AND (A24 <= 30)) AND (CLOSE <= A25)) AND (CLOSE <= A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18 >= A19) AND (A21 = A20)) AND ((CLOSE / (REF(CLOSE,1))) >= 1.035)) AND (A24 <= 30)) AND (CLOSE <= A25)) AND (CLOSE <= A26)) ;
A31:=A30 AND (FILTER(A30,20));
DRAWICON((A28 OR A31),决策线,1);
DRAWTEXT((A28 OR A31),决策线,'←黑马'),COLORRED;
{DRAWTEXTREL(3,30,'XXXX:XXXXXXXXX'),COLORWHITE;};
DRAWTEXT(CURRBARSCOUNT=89,60.1,'蓝柱在红线上逢低介入,蓝柱在红线下逢高离场!!'),COLOR0000FF;
 
附图3
操盘密码
 
N:=21; M:=5;
天:400,POINTDOT,COLORBLUE,LINETHICK4;
海:100,POINTDOT,COLORRED,LINETHICK4;
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),N);
TL:=SUM(IF(CLOSE
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),N);
VAR0:100*(TH*2+TQ)/(TL*2+TQ),COLOR0000FF,LINETHICK2;
VAR1:MA(VAR0,M),COLOR00FFFF,LINETHICK2;
{DRAWBAND(VAR0,RGB(255,0,0),VAR1,RGB(0,0,220));}
W:=CROSS(VAR0,VAR1);
WL1:=VAR1<100;
WL2:=VAR1<150 AND VAR1>REF(VAR1,1);
WLT1:=W AND WL1;
WLT2:=W AND WL2;
TJ1:=FILTER(WLT1,5);
TJ2:=FILTER(WLT2,8);
STICKLINE(TJ1,0,80,4,0),COLOR000099;
STICKLINE(TJ1,0,80,2,0),COLOR0000BB;
STICKLINE(TJ1,0,80,1,0),COLOR0000DD;
STICKLINE(TJ1,0,80,0.3,0),COLOR0000FF;
DRAWTEXT(TJ1,83,'全仓'),COLOR00FFFF;
STICKLINE(TJ2,0,50,4,0),COLOR990099;
STICKLINE(TJ2,0,50,2,0),COLORBB00BB;
STICKLINE(TJ2,0,50,1,0),COLORDD00DD;
STICKLINE(TJ2,0,50,0.3,0),COLORFF00FF;
DRAWTEXT(TJ2,53,'追买'),COLOR00FFFF;
SAL1:CROSS(VAR1,VAR0) AND VAR1>250;
SAL2:VAR0>400;
SAL:FILTER(SAL1 OR SAL2,5);
DRAWICON(SAL,VAR0,15);

青云直上的三个买入选股

青云买入
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100; AA30:=MA(C,30); 三拾日乖离率:=(C-AA30)/AA30*100; MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)

青云加仓
AA05:=MA(C,5); BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416; 速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1); 加速度5:=EMA((速度5-REF(速度5,1)),3); AA10:=MA(C,10);AA20:=MA(C,20); AA30:=MA(C,30); 三拾日乖离率:=(C-AA30)/AA30*100; 加仓:FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;

青云狙击
AA05:=MA(C,5); AA10:=MA(C,10);AA20:=MA(C,20); AA30:=MA(C,30); BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416; BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416; BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416; 强势狙击:FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);  

0

  • 评论加载中,请稍候...
发评论

    发评论

    以上网友发言只代表其个人观点,不代表新浪网的观点或立场。

      

    新浪BLOG意见反馈留言板 电话:4006900000 提示音后按1键(按当地市话标准计费) 欢迎批评指正

    新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

    新浪公司 版权所有