加载中…
博文
标签:

股票

指标

分类: 同花顺-指标源码













具体操作指导,请见如下视频:

阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
2016年11月26日-几个跟踪股票k线分析讲解

阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
如何安装同花顺K线指标
 
阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
(2016-11-26 13:04)
标签:

杂谈

阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
(2016-11-06 21:09)


MA(C,5),colorwhite;
x:=(3*C+L+O+H)/6;
多空线:(20*x+19*REF(x,1)+18*REF(x,2)+17*REF(x,3)+16*REF(x,4)+15*REF(x,5)+14*REF(x,6)
+13*REF(x,7)+12*REF(x,8)+11*REF(x,9)+10*REF(x,10)+9*REF(x,11)+8*REF(x,12)
+7*REF(x,13)+6*REF(x,14)+5*REF(x,15)+4*REF(x,16)+3*REF(x,17)+2*REF(x,18)+
REF(x,20))/210,colorff00ff,linethick1;
var1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
var2:=REF(var1,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var3:=REF(var2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
var4:=REF(var3,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var5:=REF(var4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
var6:=REF(var5,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var7:=REF(var6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
var8:=REF(var7,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var9:=REF(var8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
varA:=REF(var9,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
varB:=REF(varA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
varC:=REF(varB,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR
var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),4,1),colorred;
varD:=CLOSE< REF(CLOSE,1) AND CLOSE< REF(CLOSE,2);
varE:=REF(varD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
varF:=REF(varE,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var10:=REF(varF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
var11:=REF(var10,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var12:=REF(var11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
var13:=REF(var12,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var14:=REF(var13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
var15:=REF(var14,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var16:=REF(var15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
var17:=REF(var16,1) AND CLOSE< =REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
var18:=REF(var17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE< =REF(CLOSE,2);
STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR
var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),4,0),COLORFFCC66;
var19:=REF(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR
var14 OR var15 OR var16 OR var17 OR var18,1) AND var1;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),4,1),coloryellow;
var1A:=REF(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR 
var8 OR var9 OR varA OR varB OR varC,1) AND varD;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),4,2),Color00ff00;

STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),5,0),COLOR00ffff;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR00c8ff;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ecff;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR10ffff;
STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR10f0ff;

STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),5,0),COLOR00d900;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR93ffd1;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR93ff22;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR24ff22;
STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090ff2;

阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
(2016-11-06 21:01)


ma5:EMA(C,5),colorwhite;
工作线:EMA(C,14),colorf00ff0,linethick1;
二号线:EMA(C,25),color00ff00,linethick1;
九号线:EMA(CLOSE,99),linethick1;
MA120:EMA(CLOSE,120),linethick1;
生命线:EMA(CLOSE,453),linethick1,colorred;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)),colorwhite;
DEA:=EMA(DIFF,9),COLORf00ff0 ;
MACD:=0.90*(DIFF-DEA), COLORSTICK;
tj:=(diff>=dea);
tj1:=(diff>=0);
STICKLINE(tj,H,L,0.5,0),coloryellow;
STICKLINE(tj,O,C,4,0),coloryellow;
STICKLINE(tj1 AND tj,H,L,0.5,0),colorf00ff0;
STICKLINE(tj1 AND tj,O,C,4,1),colorf00ff0;
Var1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(Var1,13)-EMA(Var1,73);
SD:= EMA(SK,2);
DRAWTEXT((CROSS(sk,sd) AND sk< -0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(sk,sd) AND sk< =-0.14 ) OR (CROSS(sk,sd) AND sk< =0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'短线'),colorred;
STICKLINE((CROSS(sk,sd) AND sk<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(sk,sd) AND sk< =-0.14 ) OR (CROSS(sk,sd) AND sk< =0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0.5,0),colorred;
STICKLINE((CROSS(sk,sd) AND sk< -0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(sk,sd) AND sk< =-0.14 ) OR (CROSS(sk,sd) AND sk< =0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,10,1),linethick3,colorred;


阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
(2016-11-06 20:57)


Var2:=IF(HIGH+LOW< =REF(HIGH,1)+REF(LOW,1),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
Var3:=IF(HIGH+LOW>=REF(HIGH,1)+REF(LOW,1),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
Var4:=SUM(Var2,13)/(SUM(Var2,13)+SUM(Var3,13));
Var5:=SUM(Var3,13)/(SUM(Var3,13)+SUM(Var2,13));
ADDI: (Var4-Var5)*100, COLORSTICK;
Var9:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VarA:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VarB:=Var9REF(CLOSE,1);
Var1A:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
Var1B:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
Var1C:=SMA(Var1B,13,8);
Var1D:=SMA(Var1A,21,8);
趋势:SMA(Var1C,13,8),colorwhite;
盘整: STICKLINE(趋势-Var1D< -65,0,7,15,2),colorgreen;
Var1E:=WINNER((CLOSE+OPEN+HIGH+LOW)/4)*1000;
波段底部: IF(Var1E>180,0,-10),color0099ff,linethick2;
aa:=VarB AND COUNT(VarB,1)=1 AND 趋势< 80 ;

阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
(2016-11-06 20:48)

A:=AMOUNT/V/100;VARA:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
操盘线:=EMA(((VARA/10)+EMA(A,10)),3);行情线:=EMA(A,3);
重心:=(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
趋势线:EMA(((SLOPE(C,22)*20)+C),55),coloryellow,LINETHICK2;
红升:IF(重心>=趋势线,趋势线,DRAWNULL),colorred,LINETHICK2;
蓝降:IF(重心< 趋势线,趋势线,DRAWNULL),colorgreen,LINETHICK2;
STICKLINE(行情线< 操盘线,H,L,0,1),colorgreen;
STICKLINE(行情线< 操盘线,C,O,2,1),colorgreen;
STICKLINE(行情线>=操盘线,H,L,0,1),colorred;
STICKLINE(行情线>=操盘线,C,O,2,1),colorred;
DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;
DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;
DRAWTEXT(CROSS(DA-DB,0),L*0.98,'B'),colorred;
JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWTEXT(CROSS(84,JH),H*1.02,'&#9734;S'),colorgreen;
买点:=CROSS(DA-DB,0) AND C>趋势线 AND 行情线>=操盘线;
STICKLINE(买点,L,L*0.96,2,0),coloryellow;
DRAWTEXT(买点,L*0.95,'买点'),colorred;

阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
(2016-11-06 20:39)


强势: 5*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),LINETHICK0,COLOR7F52AF;弱势: EMA(MA(强势,5),3),LINETHICK0,COLORA6B8C1;
STICKLINE(强势>=弱势,强势,弱势,5,0),COLOR7F52AF;STICKLINE(强势<弱势,强势,弱势,5,0),COLORA6B8C1;
STICKLINE(强势>108 AND 强势>=弱势,强势,108,5,0),COLORFF0000;
STICKLINE(弱势>108 AND 强势<弱势,弱势,108,5,0),COLORFFFFFF;
STICKLINE(强势<0 AND 强势<弱势,强势,0,5,0),COLORF00FF0;
STICKLINE(弱势<0 AND 强势>弱势,弱势,0,5,0),COLORF0F000;
V1:= MA(CLOSE,5)=HHV(MA(CLOSE,5),20);V2:= MA(CLOSE,5)>MA(CLOSE,20);
V3:= COUNT(MA(CLOSE,1)>REF(CLOSE,1),3)=3;
风险: IF(V1 AND V2 AND V3,30,0),LINETHICK0,STICK,COLOR00FF00;
V11:= MA(CLOSE,5)=HHV(MA(CLOSE,5),120);
V21:= MA(CLOSE,5)>MA(CLOSE,120);
V31:= COUNT(MA(CLOSE,1)>REF(CLOSE,1),3)=3;
高风险: IF(V11 AND V21 AND V31,60,0),LINETHICK0,STICK,colorred;
底部: 5,LINETHICK0,COLOR00FFFF;
开仓:IF(CROSS(强势,底部),60,0),LINETHICK2,STICK,COLOR00FFFF;DRAWTEXT(开仓,50,'开仓'),COLOR0000FF;
越天: 108,LINETHICK0,COLORFF9D00;逃顶: IF(CROSS(越天,强势),1,0),LINETHICK0,STICK,COLORFF9D00;
STICKLINE(CROSS(越天,强势),90,108,3,0),COLORFF9D00;DRAWTEXT(CROSS(越天,强势),85,'收仓'),colorgreen;

阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
(2016-11-06 20:35)


源码:
MA8:MA(CLOSE,8),colorwhite,LINETHICK1;
MA21:MA (CLOSE,21),colormagenta,LINETHICK1;
MA60:MA(CLOSE,60),colorgreen,LINETHICK1;
买线:=EMA (C,2);
卖线:=EMA(SLOPE(C,8)*1+C,8);
BUY1:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);DRAWTEXT(BUY1,LOW*0.95,'出击'),colorwhite,LINETHICK5;
DRAWTEXT (SEL,HIGH*1.05,'回营'),colorwhite,LINETHICK5;
STICKLINE(买线>=卖线,LOW,HIGH,0.1,0),colorred ;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,3),colorred ;
STICKLINE(买线<卖线,CLOSE,OPEN,3,3),colorcyan;
STICKLINE(买线<卖线,LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,2.5,0),colorwhite;

阅读  ┆ 评论  ┆ 转载 ┆ 收藏 
个人资料
智慧杰
智慧杰
  • 博客等级:
  • 博客积分:0
  • 博客访问:317,017
  • 关注人气:90
  • 获赠金笔:0支
  • 赠出金笔:0支
  • 荣誉徽章:
博主的微信号
博主的微信号: Iamricherman
优秀博文推荐
毓秀
访客
加载中…
好友
加载中…
雅虎访问统计
 
留言
加载中…
评论
加载中…
  

新浪BLOG意见反馈留言板 不良信息反馈 电话:4006900000 提示音后按1键(按当地市话标准计费) 欢迎批评指正

新浪简介 | About Sina | 广告服务 | 联系我们 | 招聘信息 | 网站律师 | SINA English | 会员注册 | 产品答疑

新浪公司 版权所有